Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

The strangest Photoshop problem I've ever had just came up... I all of a sudden cannot right click, click and drag, use modifier keys (I can push B for brush, but can't say Ctrl-O for open) or long click (I cannot select the secondary tools such as switching between the paint bucket and gradient tools).

I tried deleting my user prefs (had to do it manually because modifier keys aren't working so no Ctrl-Alt-Shift), and that works for literally a few seconds and then the problem reappears. I can't recall doing anything strange to trigger the error; I was using the program just fine and suddenly I couldn't do anything I needed to. I'm having no issues with other software, even other Adobe software. I'm running CS5.5 on Windows 7 Pro. Has anyone encountered this problem before?

share|improve this question

closed as off-topic by Scott, Bakabaka, Random O'Reilly, Ryan, Alan Gilbertson Jun 23 at 17:48

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This appears to be a tech support question about fixing technology to work as advertised. Please edit the question so that it pertains to using technology to solve a design problem. You may want to check if it hasn't already been asked in Super User. In many cases, contacting the manufacturer is the quickest option." – Scott, Bakabaka, Random O'Reilly, Ryan, Alan Gilbertson
If this question can be reworded to fit the rules in the help center, please edit the question.

add comment

2 Answers

up vote 3 down vote accepted

Running Synergy is a common cause of this.

Switching synergy to application mode instead of service mode fixes this.

share|improve this answer
    
That must have been the problem -- I remember playing around with Synergy back then (I had never used it before that). I actually just reinstalled Windows after a while and never put Synergy back on, and now PS is running fine. –  BitFiber Aug 13 '12 at 1:11
1  
Thank God for Google sending me here to your answer. Solved my problem with Adobe and Synergy. –  Keith Jan 30 '13 at 18:58
add comment

There isn't a way to delete preferences from inside Photoshop, so the modifier key problem in Photoshop should have no effect. (You have to hold down Ctl, Alt and Shift before Photoshop starts, and answer "Yes" to the dialog. I'm assuming that's what you did.)

The next echelon of handling is to uninstall Photoshop, then reinstall Photoshop from the DVD or your downloaded suite installer. Before you go that far, you might want to double-check that your mouse and video (yes, GPU drivers can have some weird effects) drivers are fully up to date.

share|improve this answer
    
Thanks for the tips. I eventually had to uninstall it, but whatever works... –  BitFiber Apr 19 '12 at 2:14
    
Glad to know things are back to normal. "Whatever works" is right! –  Alan Gilbertson Apr 19 '12 at 3:40
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.