Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I have had this issue for quite a while, and have found no info to help me. Also, the issue doesn't always show up. What is happening is when I select something with the marquee tool, the selection doesn't start at the position I click. It's usually a few pixels off. It also does this with the ruler tool. I'll click at a point to start measuring and the ruler starts at a completely different spot. Really annoying! Anyone else have this problem and/or know a way to fix it. I'm using Photoshop CS4 btw. Thanks!

share|improve this question
add comment

3 Answers

I've seen this before as well. I was able to fix it by disabling “Use Graphics Processor” under Preferences / Performance (I'm using CS6, so the names may be slightly different).

There's a little more discussion here: Photoshop: Inaccurate selections with Radeon graphics cards on Mac OS

Of course, disabling GPU will slow things down...

It's worth noting that I'm not seeing this issue now (CS6 / 10.7.3 / Mac Pro / ATI Radeon HD 5770).

share|improve this answer
    
Hmm, I may try that. Don't want things to be slow though :( haha. Thanks! –  ansarob Apr 24 '12 at 18:14
    
I had this problem when using CS4 + XP64. However, when I upgraded to Windows 7 and CS5, the problem went away (I'm probably also using newer drivers than I had back then). I guess Mac users will have to either dualboot Windows 7 and buy a Windows license for Photoshop, or file a bug report with Apple and ask them to fix the drivers. –  Lèse majesté Apr 24 '12 at 22:09
    
@Lèse: I'm not seeing the issue now. When I saw it, I think I was using CS4 and a different Mac. I haven't seen it in a while, certainly not with CS6 and my current Macs. –  Marc Edwards Apr 25 '12 at 0:23
add comment

I have had this problem myself in Photoshop CS5 running Snow Leopard on a Mac Pro. No graphics setting changes have permanently kept this issue from coming back up. However, when it does, pressing F to cycle through screen modes clears the issue for me.

share|improve this answer
    
Okay, I'll try that, thanks! –  ansarob Apr 24 '12 at 18:14
add comment

May be the pixels from the marquee tool (select range). Start by selecting the inner pixels. For example, if a box is 250px wide, start by selecting from the 2nd pixel.

share|improve this answer
    
I'm not sure what you mean, sorry –  ansarob Apr 24 '12 at 19:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.