Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for professional graphic designers and non-designers trying to do their own graphic design. It's 100% free, no registration required.

(N.B. This could be a Win8 beta bug)

In Adobe Illustrator CS5 version 15.0.2 on Windows 8 Consumer Preview 64bit I have several paths. When I set their stroke to almost any colour I can see them. For example here they are in black:

black stroke

(Note that I have my artboards hidden using the 'View' -> 'Hide Artboards' menu, and I have the document set up simulating (green) coloured paper using the Document Setup Simulate Colored Paper checkbox.)

But if I change the stroke to white, I cannot see the paths:

white stroke

Nor can I see the one with white fill.

They are still there, you can see the anchor points etc. when the paths are selected, but they are not visible. What's going on? Is this a bug (I'm using a beta OS) or am I missing some setting I need to make white strokes visible? They really are white, exporting to PNG looks fine, why can't I see them in Illustrator?

==== EDIT ====

Over on the Adobe forum someone's suggested that white (in the case of process white) is the color of the paper; and that in my case the paper simulation is green, so the strokes are as well. She suggests that if I want a green background, I should create a green rectangle and that if I want to print with white ink, I should create a spot color white.

But if I add a green rectangle so that the white stroke is visible, I'll need to remember to turn it off before exporting as I need a transparent background on the final PNG. Is there a way to set Illustrator so that I can see a white stroke and white fill on a green background without making the green part of the work itself?

share|improve this question
    
I have no fracking clue, but +1 for using "N.B." and using it correctly. Quite refreshing. :) –  Lauren Ipsum May 9 '12 at 14:17
    
Illustrator version? How is "document set up to simulate coloured paper"? (the transparency grid?) Transparency panel isn't set to Multiply is it? –  Scott May 9 '12 at 14:24
    
@Scott I've edited the question to include the information you've asked for. –  dumbledad May 9 '12 at 14:33
    
@dumbledad Farray has the answer below :) I can replicate with Overprint Stroke ticked. –  Scott May 9 '12 at 14:36
2  
"Consumer Preview" = Beta? Eh, Adobe software is ALWAYS beta. My guess it's just a bug. –  DA01 May 9 '12 at 14:47
add comment

2 Answers

up vote 2 down vote accepted

Seems to be a fault in the Simulate colored paper feature perhaps.

If you turn on the Transparency grid (View > Show Transparency Grid) the strokes will appear. It doesn't matter whether you have the Simulate Colored Paper checked or not. It's the transparency grid that is causing the issue. You need to view it in order for the white to show.

In any event, with the transparency grid visible, you can create white objects, and save for web without the green background visible.

share|improve this answer
    
Thanks @Scott that works. With transparency grid visible I can see the white strokes and fill without needing to add additional rectangles as background. –  dumbledad May 9 '12 at 15:44
add comment

This could be an overprint issue, but I'm not so sure. This is not an overprint issue. See Update 2.

Check your view settings and the object attributes for Overprint settings. If Overprint Preview is turned on, and the object attribute for Overprint Stroke is set to true, your white stroke will not be displayed on screen.

If this is the case, you should see a warning on the object's attributes: enter image description here

Illustrator should warn you when you have an object flagged for overprinting white, but it may not do so if the object was set to overprint with a different color and then changed to white.

However... if this was the problem, the white stroke shouldn't be showing up in the PNG export either. This might just be a beta bug between Windows and AI.

Update: Since you're not errantly creating overprint objects, the next steps are to start debugging. Here's what I would try (1 at a time, and in this order): save the AI file and open it on a computer that isn't running Win8 Beta; create all new objects; create an all new files; reset AI's preferences; reinstall AI.


Update 2: The comments on the Adobe forum are correct. Using the Simulate Colored Paper option does adjust what the document thinks is "white". To get around this, disable Simulate Colored Paper. Create a layer with your green fill background and edit the Layer Options to set "Template" property to true. This layer will become locked and will be visible in your editor but will not be visible if you produce your PNG using Save For Web.

share|improve this answer
    
Yup.. I think you nailed it. –  Scott May 9 '12 at 14:32
    
@Farray I cannot find overprint settings, but the overprint preview is not turned on (it's set to pixel preview) –  dumbledad May 9 '12 at 14:39
    
Window > Attributes. –  Scott May 9 '12 at 14:40
    
@dumbledad How about white fill objects -- are they visible? –  Farray May 9 '12 at 14:44
1  
@dumbledad Yup, that's what I meant... but I didn't realize that Export retains the template layer (I'd tested with Save For Web). Bizarre quirk: Export will show the template layer, but SFW will not. –  Farray May 9 '12 at 16:03
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.