Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for professional graphic designers and non-designers trying to do their own graphic design. It's 100% free, no registration required.

I have problems saving my photoshop file as a pdf or eps vector graphic. It wont include some of the layers and I cant see why. See screenshot below:

screenshot: psd (left), pdf (right)
enter image description here

I tried out photoshop cs5 and cs6, both wont work on the file. example: psd and pdf file (zip)

Can anyone tell me whats wrong with my psd file? I have other similar graphics where the export to pdf works as desired.

thanks for any hints.

update1: blending mode is normal, there are no differences between the layers which are displayed and the layers which are hidden.

i tried multiple pdf-readers (adobe reader, document viewer, texworks viewer), this shouldn't be the problem. in addition, opening the pdf in illustrator gives the same result.

update2: rasterizing the layers is a workaround, but I need vectorized output, that's why I save it to pdf/eps...

update3: as i'm in hurry and i need this for my bachelorthesis i used the "dirty" workaround mentioned by Martie and rasterized the layers. the result is OK for my needs.

still, it would like to find out how this happened to avoid such hassle in future.

share|improve this question
    
What are the blend modes of the missing layers? Do you have Reader set to show overprints (in the preferences)? –  Scott May 25 '12 at 11:25
    
what is the reason why people are voting down this question? i've tried to add as much information as possible to the questions and the problem is still not solved. please, add a comment if you see any possibilities to improve this question, thanks! –  vertoe Dec 20 '12 at 9:10
add comment

5 Answers

up vote 2 down vote accepted

The reason that behaviour takes place is that you have constructed your layer shapes in the wrong way or you copied and pasted from another program like Illustrator and something went wrong with the shapes in that process.

I opened your file and discovered you have paths on your shape layers that are useless, they just sit on top of your shapes (on the same shape layer). I have deleted some of those paths to demonstrate my theory and here you go: problem fixed. You will see that some layers still have problems but some are appearing now (because I fixed those).

Click to download fixed files

How to repair a .pdf with a missing layer:

  1. Open the .psd source file
  2. Select in the Layers Panel the shape layer that is not showing
  3. Select in the Tools Panel the Path Selection Tool
  4. Click inside the shape to select
  5. Press delete to eliminate extra paths that are sitting on top of your shape on the same layer as your shape
  6. Save as .pdf to see the result
share|improve this answer
    
looks good, seems you solved it. could you explain how you deleted the paths exactly? i can't figure out the differences between your psd and my psd file. –  vertoe May 21 '13 at 19:27
    
make sure you have selected in the layers panel one of the layer shapes that are not showing then select the Path Selection Tool in the Tools Panel then click inside the same layer shape you have selected and press delete. At first glance nothing happened. Well, nothing visible but if you Save as .pdf now you will see the difference. –  Adrian May 23 '13 at 10:31
    
You can also select those extra paths with the Path Selection Tool like I've explained above then drag them around to understand better and to see how they look. –  Adrian May 23 '13 at 10:42
    
Not bad, I would have never figured that out myself. You might wish to improve your answer and merge the comments into it. :) –  vertoe May 24 '13 at 7:37
add comment

You can try 2 things.

  1. Raterize, and flatten all your layers, and then save it as a pdf.

  2. Download bullzip pdf printer from here http://www.bullzip.com/products/pdf/info.php instal the program, and see if it works like that

As for the pdf printer. You instal it, print your document, and at the printer settings you select bullzip PDF printer.

Hope this works.

Update:

Sorry no luck with the settings for me.

Now I've been thinking to do this in another way. I don't know if you are familiar with smart object, but it basically is merging layers into one layer, but always being able to access those layers later.

To do this you do the following.

You select either all your layers, or select your vector layers. Then right click on one of the selected layers, and choose convert to smart object. This will put all those layers in one smart object layer (not 100% sure if it stays vector though).

Then when you double click on the smart object, it will open up a new window, where you can see all the layers inside that object, and edit them, also changing them in your original document.

Then try exporting it as a PDF again, and hope for the best.

Hope this does the trick for you :)

share|improve this answer
    
As an answer to your update. Wouldn't it be easier to create this in illustratot then? –  Martie May 26 '12 at 12:40
    
yes, creating this in illustrator would be the correct way to do this. but i did this in photoshop with the intention to create png files. the need to save this as vectorized images came up later. –  vertoe May 28 '12 at 20:39
    
I will have a quick look at the pdf settings on my pc later and give you an update on wether there are any settings there –  Martie May 29 '12 at 9:18
add comment

File -> Save as -> Format : Photoshop PDF ; remove the tick mark next to "Layers" -> Save

share|improve this answer
    
I tried this in CS5 and it did not work. –  Johannes May 30 '12 at 15:49
    
Indeed this does not work... –  vertoe May 30 '12 at 18:53
add comment

Echt interessant.

When I went and created a duplicate of the green shape that does show up in the output it worked just fine. For some reason just the cells don't show up.

If you have to do this in Photoshop then I could create one big background shape and draw black rectangles as the stroke.

But I would really recommend to remake this in Illustrator, you shouldn't run into as many issues. It shouldn't take too much work.

share|improve this answer
add comment

Since Export Layers to Files is run by some script all I had to do was find that script, then find the function which saves the layers to files, find which part of the function does the numbering prefix.....

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.