Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I have a 2000x1500 image created with Photoshop CS6 Extended. When I save images in different formats for re-use in other programs, e.g. PNG, the image quality will suffer. I have nice basic gradiants and layout overlays but when I save it, the transparency will suffer a lot.

What to do? I would like to use PNG because I need to send that image to one company so they can print it (only PNG supported...).

share|improve this question
2  
Are you using 8bits per channel, or 16bits, or 32bits? Are you saving a PNG-24 image? If you're saving a PNG-24 and using 8bits per channel in Photoshop, the PNG can (and should) be perfect. We'll need to know more about the situation though. –  Marc Edwards Jun 6 '12 at 22:59
    
Are you using these images in iPhone? If so, and if you are saving for web, make sure you check the "Interlaced" box –  Yisela Jun 7 '12 at 2:54
    
The printer only supports PNGs? Very odd. –  DA01 Jun 7 '12 at 3:16
    
When I save it as png, it will prompt me "PNG Options" window which let's me only select compression and interlace. Nothing about channels. –  MikkoP Jun 7 '12 at 6:35
    
The document's colour depth can be seen under the Image > Mode menu. It should say "8 Bits/Channel" or similar. "image quality will suffer" — Please add more info about that. –  Marc Edwards Jun 7 '12 at 11:51

3 Answers 3

up vote 4 down vote accepted

It seems like you're noticing an RGB colour management issue.

PNGs saved from Photoshop can't have ICC Colour Profiles attached (the PNG format supports it, but PNGs with profiles are very rare).

If you'd like what's shown in the Windows photo viewer to match Photoshop, then you'll need to set up Photoshop in a way that it doesn't colour manage RGB images.

Here's how to do that:

Setting Up Photoshop For Web, App and iPhone Development

Step 2: Open a document and go to Edit → Assign Profile, then set it to Working RGB. This must be done for every single document you work on.

Please note that this step is ok as is, but there's a better way... you should set each document to "Don't Color Manage This Document".

After setting things up properly, your Photoshop document should now match Windows photo viewer.

share|improve this answer

Try using the save for web and devices menu option as opposed to save or save as and switching the file type to png. This may pull up a different dialogue window for you. Thus giving you greater control over the options for saving!

Best of luck!

share|improve this answer

Save for web and devices is the best solution. Just make sure you adjust your settings, so the quality is not lost, but also make sure it doesn't take too much space on hard disc, because you can have trouble with opening it or even printing it. It can take very much time in that case. Also, use PNG 24 image setting.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.