Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I have a problem with Adobe InDesign. When I change the page's background color (by modifying the Swatches>Paper color), and export it to PDF by going to File>Export, in InDesign - the outcome of that has a page with a default (white background).

I'm an InDesign beginner - in fact this is the first time I every used it. This is how it looks:

Image

[Note, I used the background's color (which is #ef4723) as the text color - so it's not transparent]

share|improve this question
    
I have drawen a sqare in the master view -- but still the preview is white - any ideas? –  user9622 Jan 29 '13 at 23:28

2 Answers 2

up vote 1 down vote accepted

The Paper swatch is meant to imitate your paper color for when you are printing to colored paper. It's like "non-printing color" as in the resulting background is really transparent.

In your example image, the "white background" is just the background color of acrobat.


To make background color for your document, I'd recommend Master pages.

From the top menu: Window > Pages In the top of this panel ( as a default ) you will have the Masters and the pages are shown at the bottom.

More instructions at the bottom

  1. Make a new master page ( or use the A-master ),

  2. Fill the master page with Rectangle tool ( Make sure to get those bleed area's as well. )

  3. Here's an example image where I have set blue rectangle along with red one into a master page. As you can see from the image, this repeats throughout all of my pages. enter image description here

    • This acts as a background for the pages you set this master page into. ( You may want to think of master pages like they were locked layers that are always at the bottom and you can assign them to specific pages easily ).

    • You can't arrange anything below the elements in a master page, unless you are in the master page of course.

    • None of the selection tools will react to the elements in master page if you're in the Page view.

    • Master pages are great for elements that are static, like if you have a header that repeats throughout all of the pages, this would be the way to go. The red rectangle in my example exists to show that you can put more than just a background color in there.

    • The bottom of my Pages panel says 1 Master and also I clearly have "A-master" selected, these two things indicate that I'm in Master page view at the moment.

    • The letter A on the top of the page thumbnails in my example image indicates that I have Master page A set to all of the pages.


Switching between Page view and Master page view

You can double click the Master thumbnail and the same thing applies to the page thumbnails. You'll be shown a clear indication of selection when a specific page is selected ( single click just selects a page ).

Making a new Master page.

Drag Master page from the thumbnail into the New page icon or Right click Master page and select Duplicate Master page..

Setting a Master page to Pages.

You can do this simply by dragging a Master page thumbnail into a Page thumbnail.

If you want to set Master page to multiple Pages at once, select the pages you want and Right click one of them and select Apply master to pages.


A little more about master pages

share|improve this answer

Because "paper color" assumes just that... the paper will be that color so there would be no ink there. Therefore no color is applied to the PDF.

Think about it... If you were to take that PDF, put it on a press and print it, would that background orange be printed if the paper were already that color orange? No. It wouldn't.

If you want a solid color for the background in the PDF, then draw a rectangle and use a different swatch.

"Paper color" never prints because it's assumed the actual stock will be that color.

share|improve this answer
    
I have added a rectangle of a color I want to my page, Arrange>Bring to Back. The result is the same as last time. –  Rafal Chmiel Jun 26 '12 at 18:30
    
Are you still using the "paper color" swatch? You'll need to use a different swatch. –  Scott Jun 26 '12 at 18:31
    
Yeah, I changed Paper Color to white again, and the background worked. Thanks! –  Rafal Chmiel Jun 26 '12 at 18:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.