Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for professional graphic designers and non-designers trying to do their own graphic design. It's 100% free, no registration required.

I have recorded an action in which I do the following:

  1. Auto tone
  2. Size 640 width
  3. Save for web
  4. Close without saving

I open a bunch of files and try to automate batch with this action. I say source opened files, destination none.

For many years I did this same thing and it worked. Now I buy the latest version (CS6) and it is broken. It fails to get the filename from the original for each exported file, and exports all images with the filename recorded in the action, overwriting all of them but the last one which is all that is in the folder when it is done. I am used to this exporting all of the images and giving them all the names of the original image. What am I doing wrong? Or is this a bug?

share|improve this question
    
Are you trying to save photographs, or web UI type images? –  jrista Jul 3 '12 at 1:15
    
Is this even something you actually want to automate? Personally, I like to check the output that would result from Save for web rather than letting Photoshop decide for me. If you're comfortable with the command line, explore Imagemagick, which lets you use commands like the following: convert *.JPG -auto-level -strip -resize '640x640' -quality 75 -set filename:orig %f 'out_%[filename:orig].jpg' This scans a folder for all .JPG files, does the equivalent of "auto tone", removes the metadata, resizes, reduces the jpg quality to 75, and saves with a variant of the original filename. –  Ananda Mahto Jul 5 '12 at 7:19
    
Have to try to redo the action in CS6? –  Dani Sep 17 '12 at 21:18
    
Does Adobe Bridge not help with this? I know you can export a batch of images to a web gallery, which will re-size and down-sample images. (Only problem will be the "auto-tone", maybe, but Bridge also has links to Photoshop) And you can certainly do a batch re-name in Bridge as well, with meta data and the likes. –  David Dilling Nov 9 '12 at 9:53
add comment

migrated from photo.stackexchange.com Jul 3 '12 at 14:33

This question came from our site for professional, enthusiast and amateur photographers.

3 Answers

This does seem like a bug to me too - the fix is:

  1. When you've recorded the action, open Window > Actions
  2. Find the action you recorded and untick the Open section before applying to a folder
  3. All works as it should when you Automate > Batch

It must record the filename on open but it should learn on Automate > Batch to ignore this command.

Hope this helps.

share|improve this answer
add comment

I was facing the similar situation. And found the solution myself. Just check your filename. Use valid character and remove numbers which appear at the beginning of filename. Good luck!

share|improve this answer
add comment

Use Record Action. And re-Play it.

Photoshop / Creating actions

Note for:
Record an action

and:
Change settings when playing an action

share|improve this answer
1  
I think they said they did that in the question. –  sheriffderek Dec 14 '12 at 7:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.