Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for professional graphic designers and non-designers trying to do their own graphic design. It's 100% free, no registration required.

Is there a way to export my artwork as PDF so that it has a transparent background? Something like exporting objects only... whenever I try to save my .ai as pdf, it always comes with a full white background. If I try to save as eps, I get a chunky white background (where it has white rectangles behind the artwork only where the artwork exists, so there are transparent chunks).

If I export as png, I get an image like what I'm looking for. Is there any way to do that in a vector format?

share|improve this question
    
What program are you importing the PDF where it "comes with a full white background"? I just saved an AI as a PDF and placed it in another AI, there is no white background... –  Farray Aug 7 '12 at 19:48
    
Why would you need a PDF without a background? –  Scott Aug 7 '12 at 22:11
    
Because I'm trying to deliver a vector-based logo for my company that a 3rd party can use when producing materials like posters and such. –  Kenny Wyland Aug 8 '12 at 20:16
add comment

2 Answers

up vote 4 down vote accepted

Long story short, .eps is the slow cousin of .pdf. Use .pdf.

Your .pdf problem is, I think, no problem at all.. As long as you save your file as Pdf 1.4 or higher, you should be good to go. Pdf 1.4 is the earliest pdf version to support transparency.

Since you said that "it always comes with a full white background", I'm assuming that you tried viewing the .pdf in acrobat ( or any other preview thingie you might have used ), which showed you a white background. I'd say that pretty much every .pdf capable viewing application has a default setting that shows a white background for convenience.

You can just try opening the .pdf in some editing application like Illustrator or Indesign or Photoshop to make sure, or In Acrobat settings Cmd+K > Page display > Transparency grid, you can turn on the view that shows you the transparency grid that is much like the one Photoshop has.

share|improve this answer
    
I was viewing the PDF in Preview on my Mac and you're exactly right. It was adding the white document background. Thank you, sir! –  Kenny Wyland Aug 7 '12 at 20:50
    
I had the same problem with Preview on Mac but you can turn it off with View->Show Document Background (Should say 'Hide' in my opinion but it works) –  OrganicPanda Jan 15 '13 at 20:47
add comment

This solution worked for me:

In Acrobat, go to Preferences > Accessibility > Replace Document Colors - toggle this to off

Good Luck!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.