Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

We have roughly 55 cards that all have the exact same text. The titles and backgrounds differ among the cards. So I've made just one AI with the different backgrounds and all the text as one copy in a layer on top.

Now I can just hide each background layer and save as PDF. But even unchecking preserve editing capabilities, the file sizes let me know that it is still including the images and backgrounds for all the hidden layers. Doing a quick test and deleting all the hidden layers brings the file sizes done considerably.

I was under the impression that saving as a PDF without editing capabilities only saved what was needed for that particular PDF. It seems I was wrong. Do I just have to keep deleting the hidden layers for each copy?

share|improve this question

4 Answers 4

A few boxes down from "Preserve Illustrator Editing Capabilities" is an option to "Create Acrobat Layers from Top-Level Layers". Make sure that is unchecked. See if that solves your problem! Source citation

As an aside, if you ever have this problem in InDesign, there's a choice front and center on the export dialog to export visible and printable layers only.

share|improve this answer
3  
Selecting any of the PDF/X presets disables this setting automatically, and in almost all cases you should be using one of these when preparing output for press. PDF/X-4:2008 uses a later PDF version that X-1 or X-3, resulting in a smaller file size. –  Alan Gilbertson Sep 6 '12 at 18:34

It's an annoyance. Illustrator has a very nasty habbit of including all hidden objects in many formats upon save/export. PDF and EPS can be the most troublesome.

The best I found I can do is to delete the hidden objects, then save. Basically it's a 5 step processes...

  1. Unhide all
  2. Delete
  3. Save As/Export
  4. Undo
  5. Hide

The Retain Illustrator Editing Capabilities will have no effect on this problem, as you've discovered.

share|improve this answer

The trick is to temporarily convert the layers you don't want to appear to Template layers, rather than hide them.

From the Layers palette, select the appropriate layers, and from the flyout menu select "Template". Unless it has changed since CS2...

Template layers will not be included in PDFs, neither will they print.

share|improve this answer
    
Just tested this in CS6 (Mac) and it works! So long as you do untick 'Preserve Illustrator Editing Capabilities'. If you tick 'Preserve...', it just hides the template layers in everything but Illustrator. Only change I can see from how you describe it is, 'Template' is set by a checkbox under 'Options for "[layer name]"' in the Layers palette flyout menu, and there are icons in the layers palette listing so you can easily see which are templates and which aren't. –  user568458 Dec 18 '12 at 13:46

Checking this option: "Create Acrobat Layers from Top-Level Layers" worked for me. I also chose the Acrobat version 8.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.