Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

This plugin to open and save as .ico in Photoshop has been around for a while, but I can't seem to make it work for CS6. According to this question in the Adobe Forums, the plug-in works if installed in C:\Program Files\Adobe\Adobe Photoshop CS6 (64 Bit)\Required\Plug-Ins\File Formats but it's not doing anything. Do you know of any alternative plugins for CS6? I'm using win seven 64 bits.

EDIT: The plugin does work, just not for images that are bigger than 256px x 256px.

share|improve this question
2  
I always use this website when I need to convert my files to ICO files: convertico.com –  Johannes Sep 10 '12 at 3:44
    
Thanks @Johannes. But I found two downsides to that site (and the others I tried): It doesn't go bigger than 256px, and when converting below 128px it creates a pack with automatic resized icons. –  Yisela Sep 10 '12 at 4:37
    
Ah, I only use it for customizing my own desktop and what not. I wasn't aware of those limitations, thank you. –  Johannes Sep 10 '12 at 4:58
    
Not really an answer to your question but more of an alternative: I have been using GIF Movie gear gamani.com to create *.ico files for quite some time now. It's not free, however. –  Bakabaka Sep 10 '12 at 12:21
    
Does the .ico format support images bigger than 256×256? I've never seen an .ico tool that allows for bigger images (things may have changed since I last looked though). –  Marc Edwards Dec 13 '12 at 0:27
show 1 more comment

12 Answers

up vote 15 down vote accepted

The full path is C:\Program Files\Adobe\Adobe Photoshop CS6 (64 Bit)\Required\Plug-Ins\File Formats. Unless it's in File Formats, it won't show up in the export options.

share|improve this answer
    
Figured out why it "wasn't working". When trying to save a 512x512 icon, the option to save as ICO doesn't appear in the list. So there's finally something "you can only do you GIMP": save 512x512 icons! :D –  Yisela Sep 12 '12 at 3:58
    
Hey, whaddaya know? Strange but true! :) –  Alan Gilbertson Sep 12 '12 at 4:08
add comment

I'm not sure if this applies in CS6, but the method that I've been using in CS4 & 5 is just to create my 16px x 16px Favicon, then Save for Web.

I save as either a .png or .jpg depending on the background, but when it asks for filename, I just add the .ico, like favicon.ico. Favicons work just fine.

I only use this for creating Favicons so I'm not sure if it would work the same for creating actual icons.

share|improve this answer
    
Have you tried it? I tried to make an ico-file to use in an application in Visual Studio, but couldn't get it to work. –  Olle Sjögren Sep 28 '12 at 12:12
    
it also works if you create a png with 32x32. –  Junior Mayhé Sep 29 '12 at 15:09
    
This would only work when you're using the file in places where PNGs are accepted as well. The file extension doesn't change the file itself - it just tells the program that it is probably an ICO, not a PNG. Since the file you're saving is actually a PNG - that is, it is encoded as a PNG, you would need an application that understands how to decode that information to be able to use it, no matter what extension you use. For web, generally PNGs are accepted as well, so that's not an issue. –  Payod Panda Jan 3 at 0:31
add comment

in addition to "file format RGB" make sure the source file is 8 bit per color! In "save as - format" .ico doesn't appear, if your file is 16 bit per color.

share|improve this answer
add comment

The solution is to use the 32-bit version of Photoshop CS6. I don't know if this is always the case, but I have Creative Cloud and installing Photoshop installed both 32-bit and 64-bit versions automatically. Just look through your start menu for the "Adobe Photoshop CS6" program (not "Adobe Photoshop CS6 (64 Bit)"). You will need to install the plugin in the following folder: C:\Program Files (x86)\Adobe\Adobe Photoshop CS6\Required\Plug-Ins\File Formats (note the x86!)

share|improve this answer
add comment

First check, if it's installed properly by looking for "ICO (Windows Icon)" under Photoshop's "About Plug-in" menu (on Windows, look under "Help").

If you can see it, then it's installed. You may not see it listed in "save as", if you are trying to save .psd as .ico. Open a .png picture and click "save as", hopefully you will see ICO in the Format drop-down list. ;)

share|improve this answer
add comment

The solution to the issue for CS6 is the properties assigned to the folder "File Formats", go to that folder (C:\Program Files\Adobe\Adobe Photoshop CS6 (64 Bit)\Required\Plug-Ins\File Formats), right click, select properties, and turn off "Read Only", not checked, not blue, blank. Then apply or save changed, then extract the file to the folder. It should now work fine.

The reason it does this is because you exported the file to that folder, it appeared to copy to the folder, you closed the folder and opened Photoshop and it didn't work. If you were to go back to the folder you'd see the file is not there because of the read only settings on the folder.

This worked for me, and should work for you. I hope. =)

share|improve this answer
add comment

The problem on 64 bit is that the plugin does not work with images higher than 256px. Reduce the size of the image and you'll see that the options are shown to save as .icp or .cur.


Señores el problema en 64bit se debe a que el pluggin no permite trabajar con imágenes superiores a 256px, reduzcan el tamaño de la imagen y verán que aparecerán las opciones para guardar el .ico o .cur.

share|improve this answer
2  
Welcome to GD.SE! I think English is the only language allowed on SE sites unless it's explicitly defined as something else, so I ran your post through Bing Translator and tidied it up a bit. –  Brendan Apr 9 '13 at 16:49
    
@Brendan Yes, you are correct. –  Yisela Apr 9 '13 at 20:43
1  
@Alex Solo se aceptan respuestas en ingles, excepto que el sitio sea en otro idioma. Ni se si ya la has visto, pero estamos tratando de comenzar un stackoverflow en español. Si te gustaria participar puedes dejar un commitment en Area 51. –  Yisela Apr 9 '13 at 20:44
add comment

I found a easiest way which is not figures out yet. After coping that "ICO format" plugin to directory.You need to do :

  • Work with any image file and make it 16*16 or 32*32 or your required size.
  • Then go save as > filename.ico .
  • Be sure put that .ico in last of file name.

Its working to me.Dont know if with u or not.Can do and see.

share|improve this answer
add comment

Like most people above I thought it wasn't working either, but it turned out my image size was too big, you have to resize to 32px x 32px or less before you can save as an .ico format.. I personally put the plugin here :- C:\Program Files\Adobe\Adobe Photoshop CS5.1 (64 Bit)\Plug-ins\File Formats.

Hope this helps

share|improve this answer
add comment

I couldn't open the ico file but save it with just photoshop without requiring any plugin. The method is like this:

  1. First Make sure Image > Mode > RGB Color is selected.
  2. Now save it File > Save as
  3. And Make sure of the format PNG(*.png) is selected.
  4. And just type yourfilename.ico
  5. And save. Done.
share|improve this answer
add comment

You just follow this path to place your ICOFormat64 plugin:

C:\Program Files\Adobe\Adobe Photoshop CS6 (64 Bit)\Required\Plug-Ins\File Formats

share|improve this answer
2  
Welcome to GD.SE! In the question, Yisela mentions installing it in that location. Do you have any further information to add? –  Farray Nov 20 '12 at 6:10
add comment

The correct location for the 64 bit version is:

C:\Program Files\Adobe\Adobe Photoshop CS6 (64 Bit)\Required\Plug-Ins\File Formats

The CS4/5 64 bit plugin works from here Just make sure you are using correct size and image mode (RGB)

share|improve this answer
    
This seems to just repeat some of the info in the question, rather than answering it. –  e100 Nov 27 '12 at 17:48
add comment

protected by Scott Oct 4 '13 at 21:06

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.