I'm typesetting a document in InDesign, copy/pasting from a TextEdit file that I copy/pasted into from a client-supplied PDF. Not sure if its the greatest workflow, but I collated all the text from the PDF into the TextEdit file because the PDF didn't have editable text, and so I could have all of the text in one place (and not use Word). I thought this would strip the text to as close as plain text as could be, so when I paste it into InDesign, I could apply a Paragraph style with no problems. But when I'm doing this, I'm getting colors that aren't even in the Paragraph style that I'm applying:

Different colors and sizes using the same style

and the formatting seems to be almost random in different instances and I don't know why. I thought I could override whatever was going but no errors are showing up in the Paragraph styles panel in any of the cases:

enter image description here enter image description here

So not sure what to do or why its doing that, and where purple is coming from when its nowhere in the style? Maybe missing something simple but I don't know what.

enter image description here

  • Dunno where it could come from, but it looks like there's a character style that is applied to your text, overriding the paragraph style settings. Check your character styles panel and delete the guilty ones
    – Vinny
    Oct 19, 2017 at 9:17
  • You could also try to have a look at InCopy. Nov 5, 2017 at 14:47

1 Answer 1


I do this often for PDFs, but I use BBEdit rather than TextEdit to ensure I'm stripping all formatting. In fact, I'll even save a Word file as Plain Text to strip it's formatting.

I suspect TextEdit is using Rich Text not Plain Text and Rich Text can contain format settings such as color size, etc. You can alter the preferences for TextEdit to use Plain Text rather than Rich Text, at least when saving. I'm not 100% certain about when working in TextEdit.

I often find it easiest to.....

  • copy all the text
  • Paste into an InDesign text frame
  • Select all
  • Apply my already configured "general" paragraph style to it all (actually apply and "Clear Overrides")
  • Then go through changing styles as needed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.