1

In my InDesign application settings I have hyphenation turned off for new documents as my default setting. When I copy one or more text boxes from a source document to a target document with hyphenation also turned off in the Paragraph panel, the pasted text boxes always have hyphenation turned on. This is true regardless of the number of text boxes copied/pasted and regardless of the combination of some, none, or all of them having hyphenation off when copied from the original document. I have to do this very often and with a large number of text boxes each time, and I do not want to have to manually turn off hyphenation for all these text boxes. In fact, I cannot do it manually, because a script is involved that does the copying/pasting/saving of the new document. I simply want to do away with hyphenation all together in settings so that InDesign does not add the hyphenation setting to pasted objects that didn't have hyphenation set when they were copied. I could conceivably alter the script to go through each pasted object, turning off hyphenation each time it encounters a text box, but if I can avoid this, I will. Not only do I wish to avoid figuring out how to code this; more importantly, depending on how many text boxes are pasted each time, looping through all the pasted objects (not all will be text boxes) would likely slow the script down many times over. Thanks in advance for any help.

Source document: no hyphenation in any text box Source document: no hyphenation in any text box

Target document: hyphenation turned off Target document: hyphenation turned off

Target document: All pasted text boxes have hyphenation turned on. Target document: All pasted text boxes have hyphenation turned on.

1

With InDesign launched and active and no document open, uncheck the Hyphenation option on the Paragraph Panel.

That will turn off Hyphenation for any new document and honor any pasted text frame hyphenation setting.

Essentially, adjusting things like this without a document open sets it's preference overall.

In addition, you may need to edit the [basic paragraph] Paragraph Style to turn off Hyphenation there. In reality, it would be best to never use the "basic paragraph" style for anything and create your own styles for commonly used settings. Custom styles will be copy/pasted into new documents and if they aren't associated with the "basic" style, they wont' take on teh "basic" settings.

  • Thanks for the speedy reply, @Scott. As I stated in my first sentence, I have already set my default (with no document open) to no hyphenation in the Paragraph panel. New documents have the hyphenation box unchecked by default. However, this doesn't seem to honor pasted text frames. When I paste text frames with hyphenation turned off into a document with hyphenation turned off, the resultant pasted text frames have hyphenation turned on. I also tried turning off hyphenation (with no document open) in my [Basic Paragraph] Style. I still get the same result. – nollaf126 Oct 31 '17 at 21:17
  • I figured it out. The target file has a + beside the [Basic Paragraph]+ Style. I noticed that it was set to hyphenate, for some reason. The file was obviously created that way. Even when I changed the style to defaults, saved the file, then closed/re-opened, the [Basic Paragraph]+ Style had hyphenation on again. There were some other odd settings in that file, too. I made a new doc with default settings, and the pasted text frames honored the hyphenation settings of the copied source text frames, just as you said. It works just fine, now. Thanks @Scott! – nollaf126 Oct 31 '17 at 21:37
  • I did also point out the Basic Paragraph style in my answer :) – Scott Oct 31 '17 at 22:43
1

I figured it out. The target file has a + beside the [Basic Paragraph]+ Style. I noticed that it was set to hyphenate, for some reason. The file was obviously created that way. Even when I changed the style to defaults, saved the file, then closed/re-opened, the [Basic Paragraph]+ Style had hyphenation on again. There were some other odd settings in that file, too. I made a new doc with default settings, and the pasted text frames honored the hyphenation settings of the copied source text frames. It works just fine, now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.