6

I have an Inkscape SVG document that when I copy and paste and object, the copy has an unexpectedly larger selection box around it. When selected, the information bar at the bottom marks it as "filtered" despite my having applied no filters to the original or the copy. How can I stop this from happening?

What objects look like when individually selected:

Two stars, one a copy of the other. Both are individually selected. The copy has a larger selection box.

What the information bar at the bottom looks like when the copy is selected:

The information bar at the bottom of Inkscape, showing "Star with 5 vertices; filtred in layer Layer 1."

7

The key is layer blend modes. SVG doesn't support layer blend modes (or layers), so Inkscape engages in some trickery to make it work. That trickery includes applying SVG filters to objects in the layer.

If you have at least two layers, and your source layer has a blend mode, when you paste, the new object will have the hidden filter.

Did you intend to use a blend mode? It's possible to accidentally change them, perhaps while using the mouse wheel or a trackpad's scrolling behavior while pointing at the blend mode option. You'll find the blend mode in the Layers dialog. If you don't want blend mode behavior, change it to "Normal." If the Layers dialog is not visible, it can be opened with Layers > Layers... from the menu, or Ctrl+Shift+L.

The Layers dialog for Inkscape; the Blend mode is "Multiply"

The immediate solution is to Filters > Remove Filters while the object is selected. If you're using blend modes, you may have to learn to live with it.

The Filters menu in Inkscape, with "Remove Filters" highlighted.

(Real credit for the answer goes to Lazur and Moini, who saved me after too many hours of tearing my hair out after unintentionally changing the blend mode.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.