0

enter image description hereenter image description hereto merge a photo into 1 hexagon, I just open a new document, open the photo I want. Then I select all on the new document and copy the photo. Then I would go back to my hexagon and just go to edit--> paste special --> paste into. enter image description here However, say I want to put a photo into multiple hexagons at once. The hexagons are actually all together if that makes it easier. So the natural thing to do is to repeat what I did above. So I copy my image as before. However, when I hit ctrl+ click on my hexagon (call it hex 1), then hit ctrl+click on my next hexagon, the hex 1 becomes unhighlighted (by unhighlighted, I mean there is no more dashed lines on the border). So I looked online and tried another method. I got to the actual layer box and hit select and click on first and last one. Now all of them are selected (including the hexagon boxes in between the first and last one). So I have selected them all but when I go to edit--> paste special, the "paste into" option doesn't work. There is only "paste into place" option. I am wondering what I did wrong. One thing I did notice though is even when I selected all the layers, I don't see any of the dashed lines on the border of the hexagon like I usually do when I hit ctrl+click on just one hexagon. I am not sure if that is the problem. Can anyone help me? Sorry, I am new to Photoshop.

  • What do you mean by hex? I'm not familiar with the way you are using that term. Do you mean a hexagon? Generally the abbreviation hex means hexadecimal. Also your question is not clear, it needs pictures/screenshots of the problem you are having. – Billy Kerr Nov 7 '17 at 13:05
  • By hex, I mean those hexagons. As you can see there is only place into place and no place into. – Matthew Cheung Nov 7 '17 at 14:39
  • Basically I want to put that image in those top hexagons. – Matthew Cheung Nov 7 '17 at 14:41
  • That's better! I can answer it now. – Billy Kerr Nov 7 '17 at 15:37
  • By the way I fixed your question - it makes no sense with the word hex/hexes! – Billy Kerr Nov 7 '17 at 15:48
4

Use a clipping mask.

  1. Put the hexagon shapes in a group.
  2. Put your image on a layer above the group.
  3. Right-Click Layer > Create Clipping Mask

enter image description here

  • Thank you very much. I still don't understand why the paste into option doesn't work with multiple hexagons but the clipping mask works. Thank you for your help. – Matthew Cheung Nov 7 '17 at 20:44
  • @MatthewCheung Paste into only works on one layer at a time. Clipping masks work with groups. Adobe says: "Paste Into or Paste Outside: Pastes a copied selection into or outside another selection in any image. The source selection is pasted onto a new layer, and the destination selection border is converted into a layer mask." – Billy Kerr Nov 8 '17 at 8:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.