0

A small issue but a persistent one: Since the early days of Illustrator I've been unable to copy a line of text from the artboard directly into the 'save as' dialog box when at the point of saving my work. Reason being the filename is always present in the documents I create for my clients and it seems unwieldy to type it out twice.

(nb I can work around it (but it's cumbersome)—and that is to copy>paste>copy again the text using the find and replace window)

copy paste into save as

  • What operating system are you using, and what version of Illustrator? I can't replicate the issue using Windows 10 and Illustrator CC 2017. Copying text from the artboard and pasting into the file name works as expected. – Billy Kerr Nov 15 '17 at 9:53
  • I'm on Illustrator CC (21.1.0) for the Mac. – Grateful_Jim Nov 15 '17 at 9:57
  • version 21.1.0 is CC 2017. Perhaps this is something you can take up on Adobe's help forums - it sounds like a bug in the Mac version. Also there's a new version of Illustrator out, worth a try maybe? – Billy Kerr Nov 15 '17 at 10:37
  • Are you copying the text object, or are you copying by highlighting the text with the text tool? – 13ruce Nov 15 '17 at 12:58
  • I've tried copying using both methods Bruce; I suspect the manner in which the text is stored on the clipboard is incompatible with what the Mac OS (in this case Yosemite) is expecting. – Grateful_Jim Nov 15 '17 at 13:22
1

From the screenshot I'd assume you're on a Mac.

I can reproduce the problem on my CS6 installation. It seems to be a buggy implementation of the text copy procedure. If I select a line of text and copy it, I can't paste it in the Save dialog.

If after copying, I deselect the text by just clicking on it (getting the blinking cursor back), the text can be pasted.

  • Following your procedure isn't working for me alas. How are your preferences set for file handling? – Grateful_Jim Nov 15 '17 at 10:21
  • Same as yours, but it shouldn't matter. They only specify what happens to the Clipboard after AI quits. – AAGD Nov 15 '17 at 10:26
  • It also works for me if i click anywhere else in the document, before opening the Save dialogue. – AAGD Nov 15 '17 at 10:29
  • Not happening for me that either. Just tried it on another mac here with CS3 and a different OS (10.6.8) – same result :-/ – Grateful_Jim Nov 15 '17 at 10:35
  • One last try: I only have the problem when I use keyboard shortcuts. When I use the mouse to copy/save/paste, all works as expected. – AAGD Nov 15 '17 at 11:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.