0

A client has provided a PDF file with vector information, and I need to make some adjustments to it. It is a complex file (an architectural design) with many different colors, line styles etc.

When I open the PDF in Illustrator (5.5) it opens ok, but all the objects lose their stroke and fill information - the paths are there and I can select them if I hover over them with my cursor, but they are completely invisible.

The information is definitely there: if I open the file in Acrobat Pro, everything shows correctly.

I tried placing the PDF in a blank Illustrator file. If I maintain the link to the PDF file, it works (everything is visible), but I cannot edit anything (it's just a linked file). If I do not maintain the link (remove the tickmark in the import box) the PDF is placed in my blank file, again with all stroke and fill information lost.

Due to the complexity of the file, manually rebuilding it (setting all stroke/fill information by hand, again) is not an option. How can I recover the information and still be able to manipulate the file in Illustrator, or what might be the cause for the loss of information?

(Unfortunately, the file is confidential, so I cannot provide screenshots or the original file. Sorry.)

Any help is much appreciated!

  • I think the original file was made in a version higher than yours. – LeoNas Nov 20 '17 at 16:15
  • Thinking this is an architectural design makes me thing of the issue I had with a PDF exported from Autocad and imported into AI. I can't remember how I fixed it though or what was the issue.. – Alin Nov 20 '17 at 17:13
  • Also happened to me. Might be a PDF generated via CAD software. Not sure you can fix this. Let me guess this is real estate work? – Lucian Nov 20 '17 at 17:34
  • Try exporting to EPS from Acrobat Pro and try the EPS - I strongly suspect your Illustrator version is merely too old if it is indeed version 5.5 (circa 1993) or CS5.5 (circa 2011) – Scott Nov 21 '17 at 2:44
  • Whoops, I indeed meant CS5.5. Will try the EPS export and report back. – cetequ Nov 21 '17 at 7:31
2

Found a solution on my own:

For some reason the PDF contained a clipping mask covering the entire page. Releasing everything from the clipping mask (Select frame, right click, in context menu click "release clipping mask" or similar [I'm on German software, don't know the English wording]) revealed all the content of the document.

Thanks to everybody for the suggestions!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.