2

I don't know if it's inappropriate to post something like this on this site but I didn't have anywhere else to relay my problem. (I'll remove it if it is.) Everybody online had something different, so it was just becoming a bit frustrating to not be able to find a solution.

I have Krita and MediBang on my desktop computer and they both work fine. No lag, no freezing, they run real smoothly. But I notice with the lines I draw, both tablet and mouse, they come out angular. It's barely noticeable in Krita, but in Medibang it's more prominent. It's really frustrating because it messes up any sketching I try to do. Sometimes the beginning of the stroke is completely straight before it follows the rest of the input. Is this due to some settings in the programs? Or is it my computer? I don't have the slightest clue what to do about it.

Medibang - Angular Lines:

enter image description here

There are marks where you can see the angles.

Krita - Straight line breaks:

enter image description here

I'm certain I don't need to clarify this, but just being safe; This isn't just messy sketching, It's called feathering; just a bunch of repetitive, short strokes that can help represent a form more accurately. I would show all examples, but this is already long enough as it is.

  • Perhaps it has something to do with your tablet? Check if the problem persists if you paint on some other program like MS Paint or whatsoever. – Jerome Indefenzo Dec 7 '17 at 17:22
3

I will try to point you "whys", and possible fixes in terms of Krita, that is the tool I use.

Your machine is too slow to correctly process strokes, dropping information.

Try playing with:

  • distance
  • precision
  • canvas size (make it smaller)
  • monitor resolution (make it smaller)
  • canvas bit depth

Generally it is not the case as strokes delay only, don't drop steps, but it can be something more serious, out from krita, like problems with your table drive, that produce some sort of latency, etc. It is a starting point, to a question for manufacturer support or developers.

Other possible case is display hardware acceleration, try deactivating OpenGL to see if it help, if you use AMD, there is a specific checkbox in performance section in settings too about AMD CPUs.

You're using no brush smothingnes or too much strong smothingnes

Krita has many stabilizing settings stabilize in particular can produce weird results if not used with patience. here are some examples of the settings available:

enter image description here

you're not using freehand brush tool

If this did not help, I have no much more clue. Try to contact your tablet manufacturer or Krita developers, they are very busy but generally they try to point some light there. Get to them with your machine detailed configuration and setup in hands (hardware used, version of program, operating system, etc).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.