0

I just ran into a weird problem.

If I select all in a layer, copy and paste, nothing happens. If I try to rotate something in any layer it doesn't work. I can see the actual tool rotating, but whatever's been selected doesn't move.

If I copy and paste into a new file, I just get a white rectangle instead of whatever was copied. However, all this works fine if I open some other file. I've never seen it do that before.

What's happening?

enter image description here

closed as off-topic by Scott, Billy Kerr, Westside, Paolo Gibellini, Luciano Dec 13 '17 at 12:36

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

  • Hi there, can you post a screenshot of your layers and what you are trying to move? – Ovaryraptor Dec 12 '17 at 17:05
  • @Ovaryraptor, here you go. I was trying to copy and past grumpy cat into a new layer %\ – Raksha Dec 12 '17 at 17:19
  • Have you tried merely relaunching the application? – Scott Dec 12 '17 at 17:19
  • 2
    Then standard maintenance.. reboot the computer.. trash preferences... etc. There's no way anyone here can troubleshoot a technical issue related to your system. – Scott Dec 12 '17 at 17:27
  • 1
    Hmmm, Mode is not greyed out for me. However, Quick Mask is on. Just switch it off. The Shortcut key is Q. It toggles the Quick Mask on/off. That would certainly stop you from applying a transform. – Billy Kerr Dec 13 '17 at 0:01
2

There are invisible Masks on your layer which are the reason for the strange behavior.

Select the layer with the grumpy cat Layer > Layer Mask > Reveal All then Layer > Vector Mask > Reveal All then right click and delete the masks that appeared next to the Layer's thumbnail.

The layer should now behave normally.

  • 1
    OMGTHANKYOU!!! What the heck, how did those get there %\ I bet there are some hot key shortcuts that I accidentally pressed, aren't there ... – Raksha Dec 12 '17 at 22:36
  • 1
    @Raksha - you probably accidentally hit the Q key, which toggles the Quick Mask on/off. – Billy Kerr Dec 13 '17 at 0:04
  • It's definitely one of the trickiest "UX bugs" of Photoshop, since the layer effect that was applied is absolutely not indicated by anything in the GUI that would point to it, it's just guesswork. – MicroMachine Dec 13 '17 at 22:32
0

From the picture you don't have any active visible layers. And you are still in transform mode.

So:

  1. Exit transform mode

  2. Create a new layer

  3. Select the image using ctrl+a

  4. Paste the image onto the new layer

Alternatively you can just use ctrl+j and just duplicate the layer.

Not the answer you're looking for? Browse other questions tagged or ask your own question.