0

I have the issue that when saving to SVG from Illustrator 2015 CC, there is a small offset between some objects, as seen below:

enter image description here

The blue area should be directly attached to the white area, but there is a transparent space between them. In Illustrator, when I put a black background behind everything, there is no transparent area, it looks as I want it to:

enter image description here

If I use a conversion tool like cloudconvert, to convert from ai to svg, this does not happen, it looks like it should.

What is the cause of this? I tried many different SVG settings when saving, none of them changed anything.

  • 1
    Try adding more decimal numbers for your point positions. – joojaa Dec 21 '17 at 16:34
  • @joojaa How is this done? I did not create the file. – ffritz Dec 22 '17 at 8:46
  • when you export a svg from illustrator theres an option for how meny decimals to include in the svg file – joojaa Dec 22 '17 at 8:48
1

A common problem - Exactly fitting objects get a narrow transparent zone between them. It's the antialiasing. Illustrator is clever enough to avoid it with native AI files, but SVGs get it. Objects should overlap to avoid the defect. That can be achieved in sevaral ways:

  • offset path
  • a stroke
  • initially bigger bottom objects
  • extra object below the seam

To be honest, you have another cause, because the transparent seam area seems to be quite wide and not the same in every seam. You can have something that conversion to SVG does not support properly. If you can give a link to a sample AI file and the resulted SVG, underhood specialists could give a better answer.

ADD: I saved the linked (link was in a comment) logo as SVG 1.1 with default settings. The result was tight when opened in Ai and Inkscape. I have a legacy Illustrator, not a CC version, so the opened AI file probably is in the beginning different than yours due the unsupported details. I do not understand well the conversion process, so I did not more tests.

I could repeat the problem by shifting the blue part a little down and left. The shift is very difficult to notice in Ai due the white color of the player and the artboard.

To get useful answers, please, add the link to the AI file and also to the consistently wrong SVG to your question. Nobody searches them in a comment under my answer.

A WORKAROUND: If you do not get a fix to the conversion, delete the white player and place a white circle under the image.

  • Thank you for the answer. I would be very glad if some specialist could have a look at the file and check what seems to be the case: nofile.io/f/wtKBgDpNfzm/TC-Logo_Weiss.ai – ffritz Dec 21 '17 at 14:20
  • @ffritz more data is added – user287001 Dec 21 '17 at 15:17
  • @ffritz probably you will not get heavyweight answers because you already have one. It's not this, but the comment after your question. – user287001 Dec 22 '17 at 0:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.