1

I am new to illustrator and I find the 2017 version extremely hard to use and it makes me very stressed! I am making a logo for my team, and I have found a picture I would want to clip. So far I've followed a tutorial that helps me clip out this section of an image. It follows as:

  1. Open picture
  2. File > Document setup
  3. Edit Artboards
  4. Adjust to pic size (outline)
  5. Use pen tool to size out shape
  6. Make pixel perfect
  7. Make clipping mask

However, when I get to step 7, this shows up

enter image description here

It doesn't allow me to clip. Can someone help?

  • You may find illustrator slighlt easier to use if you go into window -> Workspace -> essentials (instead of essentials classic thats totally f*ed up default) – joojaa Jan 2 '18 at 13:18
  • 2
    I think that the error message says it all. – WELZ Jan 2 '18 at 14:34
7

You have to select more than one object. Both the path/shape that you want as clipping mask, and the object(s) you want to mask. The mask path/shape must be the top object in the layer.

  • 1
    This is the answer... the alert could not be more clear that you need to select more than 1 object. – Scott Jan 2 '18 at 13:43
3

tl;dr: To solve your problem, all you need to do is leave Isolation Mode, and then re-try to select both objects and apply the Clipping Mask.


As H.W. Sanden says, you need to select both objects. Likely, this is impossible in the situation you show in your screenshot, because you have entered the Isolation Mode for your clipping shape. Let me explain.

Isolation Mode is a mode in which you, you guessed it, isolate an object (or group of them) to work on that (group of) object(s) and them only. The rest of your object will be 'washed out', and locked. You can't interact with them in any useful way.

This is great if you actually want to just work on that object. It really sucks when you want to interact with other objects again, because entering and exiting Isolation Mode is very non-intuitive.

To enter Isolation Mode, use the Move tool (black arrow) and double-click on any object or group.

To exit Isolation Mode again, either click the arrow pointing left on top left of the document, right under the tabs with opened document names or double click with the Move tool on any spot where there are no selectable objects.

  • 1
    Good catch with the Isolation mode. I'd move the TL;DR to the top though :) – Scott Jan 2 '18 at 13:59
1

Sorry, that can be irritating... Try not to click on that shape twice. Otherwise you're getting inside of the shape. Your shape is the mask, select both of them (the shape and the picture beneath) and 'make clipping mask' (by choosing the option in pop up menu).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.