In the layers dialog, there are two things you can lock and unlock: pixels (looks like a paintbrush icon), and the alpha channel (looks like a checkerboard next to the pixels icon).

Supposedly, you click the alpha channel to lock it, and then you can't change the alpha channel. When you click it again, it's supposed to be unlocked and you can change it.

The icons seem to vaguely change from locked (looks like a fat checkerboard, or one with rounded corners) to unlocked (sharp, square corners) - all somewhat visible when you change the focus to a different control on the screen.

The designer of this concept should be put in front of a firing squad, but now that I know how to lock AND UNLOCK, the unlock seems not to work: I can't change the color to alpha to make a transparent background. I'd been doing it all day with other images; now I can no longer do this operation, even with images I'd previously changed.

Am I missing a global setting somewhere? I just need to change a color to alpha.

I'm using Gimp 2.8.14


Here are screenshots:

enter image description here

enter image description here

It's hard to tell, but the top one's lock icon is a little fatter and rounded in the corners than the bottom one. Those are the locked and unlocked modes for the alpha channel.

I've restarted Gimp, and reloaded previous images which I had no problems editing.

  • Can you please update your post with some screenshots of what you are experiencing? Jan 5, 2018 at 21:23
  • @Ovaryraptor - done
    – Andrew Jay
    Jan 5, 2018 at 21:42
  • Instead of wishing for someone to be put to death for the decisions they made in regard to software interface design, how about suggesting a different implementation, and, if possible, also providing an appropriate patch? Jan 5, 2018 at 22:43
  • That was sarcasm. I only prescribe capital punishment for murder or egregious abuse of travelling in the passing lane. Different implementation: circle with slash; lock icon (locked/unlocked); grayed out/darkened; on/off slider; green/red light. There are many possible scenarios. But my question wasn't about a suggested change to the horrible UI, so maybe is out of scope. The patch is a good idea, and I've done a few patches over the years - but not because I determined it is an appropriate change to make, that has to be done by stakeholders, of which I'm not. I'll suggest the change tho
    – Andrew Jay
    Jan 5, 2018 at 23:01

3 Answers 3


The problem has nothing to do with the alpha-lock. The image is in color-indexed mode, and in that mode many restrictions apply. In particular, in that mode, transparency isn't progressive but binary (fully opaque or fully transparent), and color-to-alpha would not do anything useful. Use Image>Mode>RGB to go to full-RGB mode, and unlock alpha if still there, and you'll get the Color-to-alpha enabled.

  • This worked for one image, but not for another. Not sure why; but I restarted with a new image and so far, no problems. Thank you for the tip!
    – Andrew Jay
    Jan 8, 2018 at 14:22
  • didn't work for me, it was already RGB Nov 23, 2019 at 10:24
  • 1
    @AntonKukoba This is an old answer, from Gimp2.8 times. In Gimp 2.10, C2A is disabled if there is no alpha channel (add one with Layer>Transparency>Add alpha channel)(Gimp 2.8 C2A added an alpha-channel automatically).
    – xenoid
    Nov 26, 2019 at 20:53
  • didn't work for me either, it was already RGB Jul 17, 2023 at 11:34
  • @PeterFlynn This is an old answer to an old question, and even the question wasn't really stating the right problem... Maybe you should ask a new question.
    – xenoid
    Jul 17, 2023 at 11:41

i think you can check to the option : lock alpha in switches so you can turn on and off modifying alpha channel by clicking on it later. choose to switches : lock alpha channel click on to turn on and off alpha channel


In my case, I right on the layer and select "Edit layer Attributes...", from there I can see what attributes are being locked and uncheck them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.