2

When I try to blend two lines, I keep getting holes in parts of the blend. I have gotten the advice to increase the number of steps an make the number of points the same but with the same result (the lower image has 300 steps, with 8 points on each path)

Anyone an idea on how I can solve this? blend1

blend2

edit: few more details:

  • both lines have a stroke of 1 px, no fill
  • the upper blend has 50 steps (not sure about the number of path points though)
  • the lower blend has 300 steps and 8 points in each path
  • Have you ruled out that this is not a rendering error? Try switching the GPU render of form view menu by choosing View -> Preview on CPU (or GPU). – joojaa Jan 9 '18 at 10:17
1

I think it's because you have "Align art to pixel grid" switched on. This option is enabled by default if you create a new document from one of the web document presets. I really do wish Adobe would fix this behaviour. It's a real annoyance and catches many people out.

I get something similar if "Align art to pixel grid" is enabled. The blend is messed up.

enter image description here

However if I switch off the "Align art to pixel grid" option, and recreate the graphic again, there is no problem. The examples below show a 50 step blend, and 300 step blend.

enter image description here

1

You probably have to tweak the lines. The blending tool in has issues when dealing with lines that cross each other at certain angles. Modify the problematic intersections until these gaps disappear.

  • Thanks I'll try that! Is there anything which would indicate issues (as in what can I do to avoid this)? – Vincent Jan 9 '18 at 9:39
  • In general, be careful with sharp blending angles. Leave the question open for a few more hours, perhaps someone more knowledgeable will chime in with more info on that. – Luciano Jan 9 '18 at 10:03
1

You can try add anchor points to lines:

  • Select Blend
  • Object->Path->Add Anchor Points

enter image description here

  • Can you clarify where to find this option, I think I might be looking at the wrong menu? !blend menu – Vincent Jan 9 '18 at 23:52
  • It's not under Blend menu item, choose main menu Object, then Path->Add Anchor Points. – emax Jan 10 '18 at 6:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.