3

this is my first post here.

I have very basic project: one frame (image/color) with text wrap, and text frame with 2 columns (or two text frames, side by side, it doesn't matter). Easiest way to describe my problem is to show some screenshots:

enter image description here 2 mm text wrap: http://oi66.tinypic.com/292bi40.jpg

enter image description here 3 mm text wrap: http://oi63.tinypic.com/a3pp1h.jpg

enter image description here 4 mm text wrap: http://oi66.tinypic.com/295ehah.jpg

enter image description here problematic area: http://oi65.tinypic.com/2l8hoap.jpg

When I increase text wrap offset on gray frame, suddenly there appears a gap in right text column, and I don't know why... Why text 'ute nonse comnien (...)' is moved to right when offset is set to 4 mm? Or if this is correct behaviour, why the whole first line of text in left column 'Non rem ium (...) que officatint au-' stays in place?

In advance thanks for your help and suggestions!

  • You could merely break the wrap uniformity and set the bottom offset to 2mm. – Scott Jan 11 '18 at 13:54
2

This behavior is actually a long-standing well-known bug...

Here's my suggested fix:
First set the baseline grid increment to the same value that your body text leading.
Then go to Text frame options > First baseline offset options > Select Leading.
Of course, in order to apply the above setting to all pages, change it in your Master page!

Please note that since this fix will work only if baseline grid increment equals to text leading value, you can't use paragraph Space After half of leading value (which is something very usual and good-looking in my opinion). But as we can see in your screenshots, you don't use Space After, so this could fix your specific case.

enter image description here

EDIT: Another solution:
Again, give baseline grid increment same value than your leading.
Then set your image frame wrapping value equal to it, or any multiple value. (Using an object style could definitely be handy here). Finally, when you expand image frame height, make sure it is snapped to baseline grid. Besides it will looks nicer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.