3

I am creating a new SVG document and when I add some text, it's messed up.

It uses a 55.99999809 pt font and a 5.29 mm paragraph spacing and I have no idea where these settings come from.

Screenshot

I understand that there have been some changes from 0.91 to 0.92 which will break line or paragraph spacing when opening old files. However, I'm creating new documents in 0.92 only.

I've tried to find the default settings in preferences. I looked in Tools/Text, but could not find it there. I could not find a related setting in the document properties.

How do I reset Inkscape so that it produces normal 12 pt text with normal spacing for new documents?

  • It's not only the base line distance, also a sticking spacing between characters can drive you crazy. Thanks for leaving this hint. – Wolf Jul 17 '18 at 14:40
4

A partial answer for the font size:

  1. Create a new SVG document
  2. Stay in selection mode (arrow cursor, F1)
  3. Choose Text/Text and font... from the menu (Ctrl+Shift+T)
  4. Set the font size to the desired value
  5. Click "Set as default"
  6. Close the document without saving and create a new one

Changing the default font size

3

In addition to what Thomas Weller has to say (thanks for the pointer!) while you have the "Text and Font" pane open, feel free to select the text tool, change the line spacing (my favourite default is 100%) and then click Set as Default in the "Text and Font" pane. You may have to change something in that pane to un-grey the "Set as default" button. And I also had to switch focus between the drawing and the "Text and Font" pane once or twice, to make the button actually respond to a click :-/ as otherwise it seemd stuck, even if it wasn't grey anymore...

Another way of going about this: in Windows at least, the user preferences (defaults) are stored in a file called C:\Users\<username>\AppData\Roaming\inkscape\preferences.xml, there's a tag with id="text", and its attribute called "style" (whose value is a long string, concatenated properties delimited by semicolons) contains a property that reads line-height:100% (by now, in my case). There are actually just two occurrences of the text "line-height" in the whole XML file, the other is within a tag called id="desktop" = probably the visual style of the GUI.

Apparently the XML file contains a number of other interesting defaults. To browse and edit the config file, use your favourite smart text editor with XML syntax highlighting. (I myself am using the VIM, but Notepad++ would certainly work fine too, and is more user friendly.)

  • 1
    absolutely. without your answer I'd given up, in my case it was the horizontal spacing between chars that "was broken" (after some writing-around-paths experiments) – Wolf Jul 17 '18 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.