So I'm trying to upload a PDF to Blurb.ca, and it only accepts the file if it's within the dimensions it requires (21x26 cm). I have my file set to 20x25 cm (which is the final booklet size) with a bleed of 0.5 cm up and down, and 1 cm on the inside and outside of the spread. But for whatever reason, the PDF is consistently exporting a bit more than that. Here's the feedback Blurb has given me:

Attached: cover.pdf (8.46 in x 10.43 in / 21.48 cm x 26.48 cm) research2.pdf (9.24 in x 10.82 in / 23.48 cm x 27.48 cm)

But the original sizes are: cover.pdf (20 x 25 cm single page, bleed of 0.5 cm all round) research.pdf (20 x 25 cm spreads, 0.5 cm up/down and 1 cm on the inside and outside)

I don't mind sending a file with a little more bleed, but it goes through the uploader, so it won't work unless it recognizes that exact file size. I did want to keep it in InDesign to keep the printers' marks and export it as an X-3 file, as the site requests. Any ideas as to why this is happening?

  • The bleed and area for trim marks is part of the PDF dimensions.
    – Scott
    Feb 25, 2018 at 2:41
  • I have already tried setting the offset to 0 and removing the crop marks...is there anything else I can do to compensate for that? :o Feb 25, 2018 at 3:34
  • EDIT: have also removed all printer's marks. Still getting an error... [Pages PDF] Pages 1-40: Invalid dimensions, got [8.268 in x 10.236 in], expected [8.125 in x 10.250 in]. Feb 25, 2018 at 3:43
  • 3
    Did you try using their InDesign plug-in and templates
    – Billy Kerr
    Feb 25, 2018 at 9:53
  • 2
    agree with billy. i have worked with blurb a few times. better use their plugin and export preset to get this right
    – Lucian
    Feb 25, 2018 at 10:52

2 Answers 2


This could be a rounding issue. Have you tried changing your settings to inch or cm directly? By looking at the PDF in acrobat. Which dimensions does it show? Navigate with your mouse in the left bottom corner.


As a test, export without extras like crops marks, page information and bleed marks. Only export with bleeds and slug. If the dimensions of the resulting PDF are what you expect, you can turn on one feature at a time until the dimensions change.

Failing everything else, you can create a new InDesign document that is the exact dimensions you want the PDF to be, without any bleed or slug, then place the PDF into that and export a new PDF with exact dimensions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.