Consider the following two files.



Background with some content on top:


How do I get a flat image that is content-background? ie. the result should be white text with the blood stains on a transparent background.

The underlying issue that I am trying to solve:

The layers "Layer 27 copy 3" and "Layer 55" (the blood stains) use "multiply" blending mode, therefore simply merging these with the text will result in:

enter image description here

  • When merging layers creates undesirable effects, and you just want the layers how they look right now, a simple workaround is select all, then Copy merged, then paste (make sure a visible non-locked pixel layer is selected when you Copy Merged). So if, for example, you try Scott's answer but the Merge Visible step messes things up, try substituting Copy Merged instead then carry on as before. Sep 23, 2012 at 17:53

2 Answers 2

  1. Turn off visibility for paragraph layer ("Each correct answer will...")
  2. New Layer above all other layers (Command/Ctrl-Option/Alt-Shift-N)
  3. Merge Visible (Command/Ctrl-Option/Alt-Shift-E)
  4. Turn off visibility for all other layers
  5. Select all (Command/Ctl-a)
  6. Copy (Command/Ctrl-c)
  7. Add Layer Mask
  8. Select Layer Mask (Command/Ctrl-)
  9. Paste (Command/Ctrl-v)
  10. Adjust levels to bring up the white nad red and reduce the black.
  11. Turn on visibility fo the paragraph layer ("Each Correct Answer will...")
  12. Save for web

book final

To retain all the blood - on or off text

  1. Set both the blood layers to Normal.
  2. Remove the mask on the one layer.
  3. Merge the two layers
  4. Choose Select > Color Range and click a white area of the layer
  5. Hit OK
  6. Inverse Selection (Select > Inverse)
  7. Add layer mask
  8. Set layer to multiply.

This leaves you with this...
(grey background used to show transparency)


You can then further mask the blood if you'd like.


With a help from the mysterious scratchpost I managed to do it.

  1. hide all the layers that are of no interest (ie. keep only the blood stains)
  2. cmd + click red channel (this will select only the blood stains).
  3. restore visibility of all the layers
  4. flatten the image
  5. cut out the selection
  6. unflatten the image, remove/hide the bloodstain layers, paste the clipboard.
  • This is not going to be the answer, because this is actually a work around for this particular case, though might help some of you who come across it.
    – Gajus
    Sep 23, 2012 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.