I am using Illustrator CS3 and trying to export my illustration. Problem is, I wanted to only export the illustration, no the background canvas area, how I can achieve that?



3 Answers 3


Unfortunately, I do not have access to CS3, I use CS5. However, I noticed that when you export, in the dialog box where you choose the file name, there's also this option: enter image description here

Make sure it's unchecked as shown, this will export ONLY the content, not the artboard.

EDIT Alternatively you can fit your artboard to your illustration: enter image description here

  • Thanks for your reply, but I am not getting any such checkbox in CS3 :( Commented Feb 23, 2011 at 7:07
  • @itsaboutcode - I edited my post, I hope this second technique works for you.
    – Hanna
    Commented Feb 23, 2011 at 7:14
  • So cropping area to fit my illustration has worked.. May be this is the only way in CS3. Commented Feb 23, 2011 at 7:18
  • @itsaboutcode - I'm sure there's another way, but due to our different interfaces I doubt I'll be able to give you a better option. But, I'm glad I found at least something that worked!
    – Hanna
    Commented Feb 23, 2011 at 7:33

I have CS3. I created a new document, drew a filled circle on the artboard, and exported to png. It clipped automatically - no need to manually crop. Which format are you exporting to?

  • My mistake, I was exporting the image in jpeg format. Sorry just new to business and Have no idea about these things. Thanks for your help. Commented Feb 24, 2011 at 15:44
  • @itsaboutcode - I didn't even consider that that may have been an issue. I always export to PNG (as seen in my screenshot). Interesting to know that that makes a difference though.
    – Hanna
    Commented Feb 26, 2011 at 22:57

I usually use this way:

On the menu bar, find object, then crop area --> make.

"Look at the two line on each corner of the artboard"

And when I export, all I get is everything inside the box. I'll try it on my Illustrator CS2 and I hope there is the same menu on CS3.

And if I want to export just the illustration, I export it as .PNG format. Make sure you have chosen the color drop down with transparent.

The dialog box will appear after we click *export* as .PNG, then choose *transparent* as the background *color*.

Not the answer you're looking for? Browse other questions tagged or ask your own question.