1

I'm using the online free version of sketchup, and after adding several objects and moving them around, I can't quite seem to get two objects to line up (snap) exactly onto each other. How do I get objects to line up perfectly?

If I move the objects as close as possible to one another, visually, and then use the measuring tool to confirm distances, I get a distance of 0" displayed, even though there is a clearly visible gap.

a zero gap

N.B: I've added an arbitrary line, 3/8" apart, just for scale. But notice how the visible gap shows up as 0"

I'm using a grid that is 1/16" (the possible settings go as low as 1/64 ), and objects seem to move in 1/16" increments. I've done all the sketching at 1/16".

The objects are 1/16" apart here:

big gap

If I move the horizontal piece closer to the vertical piece by "one notch", I still end up with a minute noticeable gap, but as the top image shows, its real measurement is 0":

enter image description here

If I keep moving another notch, then the overlap is clear, confirming that the previous "notch" was as close as I could get it:

enter image description here

I'm only working with 90degree angles. And I've tried moving the two pieces independently in the hope of "resetting" the grid, with no noticeable change.

Just in case, I'm showing a snapshot of my 'view' settings here:

view settings

  • 1
    Any chance Blender might be better for your needs? because we have a whole community of blender users. Sketchup not so much. – LateralTerminal Mar 15 '18 at 14:26
  • Can't say I've used Blender. I know of it. I chose sketchup mostly for apparent ease of use for creating woodworking assembly diagrams. I later discovered a forum dedicated to SketchUp help (forums.sketchup.com) where I also posted this question. I will post my answer here. – init_js Mar 15 '18 at 18:40
  • I'll be interested to see your answer. I've used sketchup before but for totally different reasons that wouldn't be useful to you. – LateralTerminal Mar 15 '18 at 18:50
1

I have simultaneously sought out help on a different forum, and received the following answer, which resolved the issue.

The solution is to select the move tool ('m'), click a corner or an edge of one component, release, move the cursor until it snaps on the corner or edge it should connect to, and click again. You can also drag the corner or edge instead of clicking and releasing, but the advantage of the click-move-click is that it will be easier to pan/zoom/rotate the camera while the selected component follows you around.

I was initially moving the component by dragging its faces, which does move the object, but does not trigger the same "snapping" options on adjacent components. Faces are easier to click on, edges and corners being so thin and easy to miss with the cursor.

This photo was provided on the answer thread to display the behaviour:

enter image description here

In the question's first picture, the initial gap which is displayed as 0", revealed itself to be a 1/64" gap when I cramped up the resolution in the "model info" pane.

If all your components are laid out in exact multiples of 1/16", and you use right angles (x90 degrees), then really it shouldn't matter if you initiate movements with faces, edges, or corners -- everything lines up. Somehow (I still don't know how/why), a 1/64" gap entered the scene, and then alignment by corner/edge became necessary.

I wish there was a way to snap all of the components to their nearest rounded up/down 1/16" grid cell. I've had to align every single component one-by-one to get them to snap on the same 1/16" reference snapgrid.

Sketchup allows you to move component by an offset typed on the keyboard. Perhaps I erroneously typed 1/64" when I meant 1/4" at some point when I rearraged the scene, and then ignored it because it had no visible effect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.