0

here is a problem that's been bugging me for a long time and as I didn't find any solution from the web, I thought it may be time to ask for help.

When I export a .psd from my 3D app with a layer of objects rendered as plain red, green and blue colours to use as masks from RGB channels I run into edges problems.

RGB layer

When I copy/paste (or copy merge/paste) the channels into layers and blend them with Lighten, Linear Dodge or anything else I always have visible edges, like pictured here.

visible edges when layered

This lead to nasty edges in the final image :

enter image description here

I also have the same problem when I invert the masks.

This happens in Photoshop CC 19.1.2 on OSX 10.13.3 in a 16 bit RGB file, but I had the same problem on earlier Photoshop versions and other image modes.

Maybe this is a normal behaviour but I don't feel like it, so if anybody is willing to shed some light onto the problem, thanks!

2

The edges are caused by the anti aliasing of the edges in your masks. The edges are not solid black or white and this can (and often does) lead to imperfect fit between masks that you would expect to meet each other cleanly.

There are two options that I know of to fix or at least mitigate this issue.

The first is to turn off anti aliasing when you export the masks if that is an option. The downside of this is that the edges of the masks will be very hard, which might look nasty. Also, there is no guarantee that they will be perfect.

The second is to adjust the masks in Photoshop. The best option is probably to use adjust levels and move the middle (mid tones) slider until the join disappears. You will be making a harder edge on the mask by doing this so you might want to apply it to both masks so that the effect is split between the two and/or apply the adjustment to isolated areas as required rather than the whole mask channel.

  • Thank you for the (super fast) answer. Second option does the trick very well! – Bolos Mar 19 '18 at 13:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.