OK, so I'm following this tutorial:

YouTube -- Illustrator Tutorial: Adding texture using a transparency mask
--jump forward to 1:50

I do everything exactly as shown:

  • first group object
  • cut the texture
  • select object
  • go to transparency
  • then make opacity mask.

After that, everything is gone as in video, but when I press CTRL+V to paste the texture (2:02 on video), it pastes just the texture itself, not the object WITH the texture.

This channel is not active anymore, so I can't ask the person who made it, I hope someone here had the same problem and can help.

Funny thing is that two days ago, I somehow managed to get the results, but now always the problem when pasting.

  • The tutorial works as expected. I just tried it. Looks like you've missed out selecting the Mask thumbnail before you pasted. – Billy Kerr Mar 22 at 20:30
  • As I posted in comment below, it works for me, but only when using .jpeg texture. With vector, it still just pastes the texture, without making mask. – Jimi Mar 23 at 22:17
  • Ok, so try disabling the "clip" option, just before you paste into the mask. – Billy Kerr Mar 23 at 23:06

This is somewhat difficult to answer without seeing what you are doing. But perhaps a little explanation will help.

When the video pastes the texture, that's all it's pasting. It is not pasting the texture and the artwork. The only thing you should be pasting is the texture. It's the texture on the mask, in addition to the artwork on the artboard, that creates the combined appearance.

Make certain your texture is on the mask by clicking the mask thumbnail in the Transparency panel and that your artwork in on the artboard by clicking the artboard thumbnail on the Transparency panel. Then make certain both the texture and the artwork overlap.

You may also need to tick/untick the Clip and Invert Mask options on the Transparency panel. Either just one or both -- depends upon the texture you are using.

If you could show a screenshot of your artwork and the transparency panel, that may help to solve your issue further.

  • Thanks for the reply. I got half results - I managed to make opacity mask without problems, BUT when using a .jpeg file. With the texture, always the same problem, it just pastes the texture. It shouldn't be different procedure for vector texture and raster image when making opacity mask if I'm not wrong. For the specific case, I used the .jpeg similar to texture, but for future I'm out of ideas. – Jimi Mar 23 at 22:16

After reading your comments I think I know what the problem might be.

When you create the mask, and select the Mask thumbnail, deselect the "clip" option, before you paste it.

Here's an example of a vector object pasted as an opacity mask on some text.

enter image description here

  • Already tried it, as Scott also suggested it. It still pastes just the texture. Thanks for the reply though. – Jimi Mar 31 at 23:32
  • Hmm . . . that's odd, because it clearly works, otherwise I wouldn't have been able to do it. – Billy Kerr Mar 31 at 23:42

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.