3

I created a path connecting different segments and than I created the 3D effect using the command extrude & bevel Do you know how I can fix the imperfections (in the 3d effect and in the connections among the segments) you see in the screenshot?enter image description here

  • merge then underlap, the problem of these impoerfections is actually a "bug" in the rendering engine, the problem it is a conflation artifact, as described more here, and here. Anyway i wouldnt use the 3d effect for this but thats just me. Also by the way it seems that variations on conflation questiosns are asked every second week. So common source of problems – joojaa Mar 26 '18 at 9:45
  • @joojaa what would you suggest instead of the 3d effect? I need to add a third dimension to these structures – Andrea Mar 26 '18 at 9:52
  • Your not really adding 3d to your structure, for all the lements you show a offset works as well – joojaa Mar 26 '18 at 10:02
  • the others who have had the same problem have usually accepted the answer, where someone suggests "put something with same color behind the unwanted seam" – user287001 Mar 26 '18 at 10:07
1

Those lines are sometimes not visible in final product. When "saving for web" if you select "preserve art" rather then "preserve type" it makes the seams less noticeable.

To get rid of the seams select the color shapes on both sides and use Pathfinder>Unite.

You can use the Magic Wand tool to select all the light blue parts and then merge them together using Unite, then the dark blue.

Not the answer you're looking for? Browse other questions tagged or ask your own question.