I've been using the demo for Cinema 4D R19 Studio without registering it and had no problems. Today, I registered it, so that I could save the file but now I can't select my model.

Left clicking does not select anything in the view port, but when I click and drag the perspective camera rotates around the point I'm clicking.

The model is an exported model from a different 3D program, but I have changed nothing on the model between using the demo unregistered and registered.

Even if I create a cube in a different file, I cannot move or select it within the viewport. If I click the movement handles and drag up, the camera just zooms in. Something must have changed during the registration. I've even tried deleting the preferences to reset them.

Did some feature get activated now that I need to turn off? I've been searching the internet for a while now and can't find anything. Any help would be greatly appreciated.

EDIT: Updating my Graphics Card did the trick.

  • 1
    I'm voting to close the question since it's not possible to answer without seeing your files/software/computer
    – Luciano
    Mar 27 '18 at 11:30

I updated my graphics card and that has solved the problem. I still do not understand how registering the program made me have to update the graphics card, but there you have it...

  • I wonder if it's possible that it was just a temporary bug and it wasn't updating graphics drivers that solved it but restarting your computer as you updated the drives.
    – Joonas
    Mar 27 '18 at 9:31
  • @Joonas Generally yes, but picking is something that is typically done in a special pick buffer or pick pass on the graphics card and it makes sense that driver actually affects the ability to pick objects.
    – joojaa
    Mar 27 '18 at 11:09
  • @joojaa, I didn't say the drivers didn't play a part in it... He said it was working with the old driver version and suddenly stopped when he registered the application. Then it started working again after updating the drivers. Doesn't sound to me like the older version was the issue... Unless the application was updated around the time of the registration and that introduced an issue in with the old drivers. My money is on restarting the computer.
    – Joonas
    Mar 27 '18 at 11:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.