0

I have a simple 32x32 pixel art image that I am working on in gimp. When I export this image as a png file, I view it using an image viewer and it seems blurry.

I have searched through the Internet but to my surprise, no solution was found. Although I did find one person with my same issue on this forum post. No one had a solution on that forum post, however.

I thought this would be a simple fix by a Google search like most things with gimp but to my surprise I could find no solution. So I decided ask you all here on this stack exchange site. Any ideas for a solution?

Edit: Here is a screenshot to show what I mean: enter image description here

The image looks sharp in Gimp but when I export, I see the above. I am zoomed in on this image but that is not what is causing the blur since it remains blurred at any zoom level and even when I import into a project I am working on.

  • 3
    The quality of a bitmap image should only be assessed at a 100% zoom level. – spike_66 Apr 1 '18 at 8:34
  • I can't replicate the problem. I created a 32 x 32 px image, then exported as PNG without any issues. – Billy Kerr Apr 1 '18 at 10:18
  • @BillyKerr View the image, does it not seem like the edges of each pixel have been blurred or softened? – Javier Martinez Apr 1 '18 at 18:28
  • 1
    You have zoomed in on the image at 718%. You can't zoom in on raster images, or they will go all blurry. You must view the image at 100% to see what it looks like properly at the correct size. – Billy Kerr Apr 2 '18 at 0:37
  • 1
    Incidentally, this has nothing to do with GIMP. The same would happen if you had made the PNG 32 x 32px in any image editor, and then zoomed in on it. – Billy Kerr Apr 2 '18 at 10:35
0

In the post you refer to, the person is making a 20x20 image and shows a 100x100 result, so there has been some scaling up. If you do the same, make sure that you are using Interpolation: None in the "Quality" options of Image>Scale image.

  • I did try this, but this seems to be for scaling within Gimp. Setting interpolation to none in the scale image options has no effect on the export. – Javier Martinez Apr 1 '18 at 18:25
  • 1
    What size in pixels is the export, and at what size are you looking at it? If it is scaled up y some random viewer, this viewer will likely not use the "nearest neighbor" interpolation which is the only one that will keep the pixels square. So if you want a bigger image scale it up in Gimp before exporting. – xenoid Apr 1 '18 at 21:07
  • I have added an edit to the post, please check that out and tell me what you think. – Javier Martinez Apr 1 '18 at 22:41
  • 1
    Can you post the raw png? – xenoid Apr 2 '18 at 8:42
0

I decided to experiment a bit I think I found the issue. I came from Photoshop before Gimp I remembered that I encountered this issue with Photoshop as well. I was using the Unity Game Engine at the time, So when I Imported, I had to tweak settings to make sure the asset looked sharp.

I am using Godot now and I imported the blurry asset into the engine. I set it to 2D pixel and it looked sharp, like I wanted. I have not yet found a way to get Gimp's exports looking sharp but it seems that the import pipelines of most game engines can easily fix this.

Although in my case, I am making the pixel art for a project on Code.org for school, which has no such pipeline like game engines do. Looks like I will have to deal with it for now but at least in actual game projects I can make my art look sharp.

  • You are encountering an issue with your image viewer - or more precisely, you are encountering a use case your image viewer has not been optimized for. Check if you can disable any image smoothing or blurring the viewer applies. – Michael Schumacher Apr 3 '18 at 11:57
0

Your image viewer applies a slight blur to images it displays. While this is a good idea for many images to avoid aliasing - "pixelized" or "jaggy" edges - it totally fails if pixelization is what you are looking for. With pixel art, you want that.

You are viewing the image at 781% its original size. This zoom factor is an issue all by itself, as any single pixel in the original image would have to be represented by 7.81 pixels in width and height in the zoomed-in displayed image. Sticking to zoom factors of 100%, 200%, 300% and so on is much better.

But even then, the viewer would still apply a blur to the displayed image, and it wouldn't look much different at 800% than in your sample image.

Check if your image viewer has an option to disable image smoothing or blurring, or something worded in that fashion.

Not the answer you're looking for? Browse other questions tagged or ask your own question.