1

My goal is to (temporarily at least) get reliable colour values on screen and in my screenshots, in CorelDRAW 2017 on windows. If I screengrab and paste into eg GIMP, the colours shift. I think what is happening is that my screenshots are being converted to my monitor colour profile.

Here's the bahaviour I'm seeing: I draw a green rectangle (RGB #00ff00), and then screenshot my desktop or the CorelDRAW window, pasting the resulting image into GIMP leads to a much yellower shade of green. This is a color value change, ie using the GIMP eyedropper shows I now have #68ff00. I believe this is due to Corel passing everything through a monitor colour profile before showing the image, and means my sRGB green is being converted into a DELL factory colour profile instead.

After much searching I came across this thread: https://forums.adobe.com/thread/1815636 which seems to describe a similar issue. In that thread, two solutions to this colour shift are described, namely:

  • Use sRGB as a monitor colour profile
  • Assign the monitor colour profile to the screenshot, then convert to sRGB.

Corel 2017 does not have any way I can see to change the monitor colour profile, and I learned that it defers (on windows at least) to the OS. Changing my device colour profile to sRGB (Control Panel->Color Management, Tick 'Use my settings', add sRGB profile and set as default, restart Corel) indeed leads to #00ff00 appearing in the screenshot. The second solution gives yet different results.

Here's what I think is happening: Original configuration:

  • Corel starts with #00ff00/sRGB internally.
  • It converts this to a DELL colour profile found via an OS level setting and displays #68ff00
  • Screenshotting my desktop leads to a file with an #68ff00 colour value, but with no embedded profile information.
  • Pasting this in GIMP shows #68ff00
  • Pasting back into corel means the colour is converted through the DELL profile a second time.

Setting my windows colour profile to sRGB leads to this:

  • Corel starts with #00ff00 internally, sRGB.
  • Display onto the monitor now does no conversion as this is also sRGB
  • Screenshot gets #00ff00, no embedded profile.
  • Pasting anywhere preserves #00ff00 value.

Using the other solution from the adobe thread above leads to this:

  • Corel starts with #00ff00/sRGB
  • Display is #68ff00/DELL
  • Screenshot / pasted image is #68ff00/None
  • Assigning DELL profile (GIMP->Image->Mode->Assign Color Profile..) leads to #68ff00/DELL (same as display output from Corel)
  • Converting to sRGB (GIMP->Image->Mode->Convert to Color Profile..) leads to #0ef842/sRGB

In all cases, if I use Corel's export selection, or Corel->Window->Dockers->Color Proof Settings->Export Soft Proof, then I get an exported file with #00ff00 in it. However, nothing I can find in Corel will change the pixels on my displays/screengrabs to #00ff00. 'Proof colors' runs things through a printer profile and changes the display colour. Ticking 'Preserve RGB values' and setting the 'Simulate Environment' to sRGB, still puts #68ff00 on my screen.

My questions are:

  • How can I temporarily bypass the monitor profile in Corel, to see and screenshot #00ff00?
  • Why does the assign DELL profile/convert to sRGB process suggested above lead to #0ef842? Is this simply the fact that some information is lost in conversion, and that applying the same profile in reverse will never yield the original colour in general?
  • What problems will I encounter if I use an sRGB profile for my monitor on a permanent basis?
  • I have had trouble with colour management in corel draw for a long time, for example, when I veiw the same colour in photoshop, it is not the same. I just made sure to have the same profiles for both softwares, which 'fixed' the problem. But it seems you are doing that, would be a good idea to ask the corel community forums. – Aasim Azam Apr 12 '18 at 14:51
1

This could have something to do with your colour settings in GIMP's preferences, especially if you have the Color managed display option switched off.

Try setting your Edit > Preferences > Color Management settings as follows:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.