2

I have a repeating art on a single background. To ease modification process I've converted it to smart object - that way I only need to modify it once, and it updates with all copies simultaneously. But inside smart object there is no background - and I have objects with blending mode multiply. shadows are meant to blend into background

I can understand why after saving my smart object multiply blending does not apply to the singular background - the background is not the part of it. Instead I get something like this:

no blending, just hideous color blob

And this is how it should look like:

shadows are delicate but visible and blended with background

Now, to my question; is there a way to make the selected layers inside smart object blend with layers outside of smart objects? I know there is a blending option called direct transition (not sure on the name tho, using diffrent language) for object groups, but there isn't one for smart objects.

Or maybe my workflow idea is flawed, and I should approach repeatable graphics issue differently?

2

Placing smart objects is essentially same as making a separate flat file and then add that into your scene just that you can go to that file if need be. Now its not pssible to have blending modes in images just normal alpha blending. Therefore not in smart objects either.

Altough in this case it is pretty irrelevant just make the shadow black.

  • That's why I ended up doing - changing shadows color to black and adjusting the opacity. In this case it worked, but I wondered if there is a way to do that without modifying the art at all. – Hassan Apr 16 '18 at 9:43
  • @Hassan Wasnt i clear it works like placing an image images cant have differnet blend modes (just one) – joojaa Apr 16 '18 at 10:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.