2

I came across a rather annoying issue while working in Inkscape. I'm trying to trace an object roughly (the object isn't a bitmap, it's a path, albeit a complex one) on a layer above it. I'm not trying to convincingly copy the object, I'm only referring to it to keep my proportions in order. Whether I could use other tools (e.g. to simplify the path I'm interested in and adjust it to my needs) is irrelevant, as I believe that my approach makes most sense in this particular context, and I think my question remains valid anyway, even if there exist potentially better approaches to my design.

I have another object on the layer that I'm working with and I'd like my mouse pointer to snap only to that object (or other objects that I might later create in that same layer, though perhaps the problem could be generalized to any object, not just layers); unfortunately, the object I'm tracing has a lot of nodes close to the area I'm working with, which makes that task nearly impossible. Zooming in helps, but for some reason with that level of complexity Inkscape seems to have serious performance issues on my setup when zoomed in (I'm aware of Inkscape's path simplifying capabilities, and if nothing else works, I'll likely have to make use of them eventually, but I digress). Controlling which kinds of entities can be snapped to might work in some cases, but be of little help in others.

Now, layers can be made invisible or locked. Hiding the layer would be counterproductive for obvious reasons. Locking it only prevents potential modification, but the objects on it are still being snapped to.

I tried googling the issue and only stumbled upon this old, long-forgotten feature request. It seems as though nothing has been done about it, but perhaps there's something that I missed and that particular feature request's status could be misleading.

Can this be done, or do I have to resort to other, less efficient methods?

3

Make a bitmap copy of your reference and lock it. It's in the Edit menu. Hide and lock the original.

Be sure you have high enough resolution. It must be set in the preferences (Bitmap > Resolution of Bitmap Copy)

2

If you make a clone of the object (Edit > Clone), I have found it stops many of the snapping options from working, except for snap to cusp nodes, and quadrant points of ellipses.

So that might be enough for you, although I'm not entirely sure since I can't actually see what you are trying to do.

Here's an example with a clone. I have switched off snapping to cusp nodes, and snap smooth nodes (including quadrant points).

enter image description here

  • It's a pretty interesting finding! Unfortunately, it doesn't really do the trick for me, but it's useful to know. I found the other answer to be much more helpful in my case, but you have my upvote anyway. – rhino Apr 17 '18 at 16:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.