1

I'm trying to delete part of a dashed line in Illustrator (I marked the part that I want to remove with a red rectangle).

enter image description here

The Dashed line was created by an horizontal line tool with Zig-Zag effect, so the anchors are as seen here:

enter image description here

I've tried the eraser tool, mark a line and then use pathfinder, lasso tool to select the part I want to remove but none of them worked.

Any suggestions?

Thank you!

  • That appears to be a raster image. Is it? If it is, you can't edit a raster image with Illustrator. (Or perhaps you merely have Pixel Preview on?) – Scott May 4 '18 at 4:29
  • I just used screenshot - this is why the lower pixels. All of the lines were drawn inside Illustrator except the red rectangle. – ValientProcess May 4 '18 at 4:33
2

Use the Pen Tool to add an anchor point to the path where you want to cut it.

enter image description here

Then use the Direct Selection Tool to select the end anchor point:

enter image description here

Hit the Delete key:

enter image description here

There are other ways...

  • You could use the Scissors Tool or Knife tool to cut the path,then delete the end section
  • You could draw a new line and use Pathfinder, then delete the end section
  • You can select the path then use the Eraser Tool to erase art of it.

All the methods essentially involve the same amount of clicks/keypresses so no one is better than another.

But with any of them, you must have the path selected.


Based upon Question update. An effect has been applied. Therefore, you must expand the effect... Object > Expand Appearance... or guess at where you want to cut the line and cut the actual path (the blue line), not the preview with the effect.

  • For some reason when I select the line I don't see the path, only horizontal blue line – ValientProcess May 4 '18 at 4:45
  • Sorry, I can't really guess at what you are seeing. – Scott May 4 '18 at 4:54
  • I've edited the question – ValientProcess May 4 '18 at 4:58
  • Do you have some effect applied to the path? That's the only reason I can think of which would cause such a selection preview. – Scott May 4 '18 at 5:01
  • 2
    You have to expand the effect... Object > Expand Appearance.. or guess at where you want to cut the line and cut the actual path (the blue line), not the preview with the effect. – Scott May 4 '18 at 5:05
3

If you want to keep the line without expanding, i mean the horizontal line with the zig zag effect, you can add a transparency mask to the line:

Select the line and click on "Make mask", uncheck "Clip" and select the mask area, the square at the right of the window. mask1

Draw a 100% black shape on the area you want to hide, and click back the left square of the window to go back to the editing shape area of the file. mask 2 And that's it Mask 3

0

Select the blue line and then Object>Expand, Object>Expand (yes, do it twice, the second time make sure "Fill and Stroke" are selected)

Select the line and then Right Click>Release Compound Path

Select the line and Ungroup

You may now delete individual dashes.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.