1

Problem

I was wondering how I would be able to import objects made in layout to SketchUp. I import it as a DWG/DXF file, and then tried to open it in SketchUp, however, I get the following message:

Warning:

Some imported geometry is extremely far from the
model origin. If you experience any instability with
your SketchUp model, please delete that geometry
from your .dwg/.dxf file and import again.

AutoCAD Entities Imported:

        Layers: 2

AutoCAD Entities Simplified:


AutoCAD Entities Ignored:

    Anonymous Blocks: 9

Technicalities

  • The units in layout I am using is 58cm by 64cm.
  • The filetype is DWG/DXF. It's DWG by default, however, there's an option to export it as a DXF. I've tried both.

Solutions Tried:

  • At first I tried importing it as meters instead of centimeters, in case maybe it was too small.

  • Through some research, I learned that when importing a DWG/DXF file into Sketchup, you can define the units used. I was 100% this would fix it, but unfortunately, even though the units in sketchup when importing match the units in layout when exporting, the problem still persists. I kept the units when importing as cm however in case this was one of several reasons for this problem.

  • I've tried zooming both in and out and then importing it there.

  • I've tried importing it both with the "Preserve drawing origin" option ticked and unticked.

  • I've also checked to make sure that there wasn't anything outside the sheet itself in layout. I did this by selecting all my objects, copying them, deleting them, and then hit the shortcut to select everything (cntl+A) and deleted anything outside of the page (if there was anything to begin with) and then pasted the objects back in onto the page.

Screenshots Layout drawings enter image description here I've also included the page and layer page, in case that's of any use.

Export options enter image description here Again, i've tried both file formats, DWG and DFX Sketchup file enter image description here

Import options enter image description here I've measured across one of the axes so you can see how far out I am zoomed.

Error Message 1 enter image description here Error Message 2 enter image description here

  • 1
    How far from the model origin is your DWG? Is it based on a digital map? Do you import it to the Sketchup origin or its original coordinates? What unit is used in the DWG? What unit are you using to import it? This is a basic list of potential sources of error. – Ovaryraptor May 9 '18 at 15:40
  • "I've tried everything": what did you try? It would help to know to narrow down the answers. – Luciano May 9 '18 at 15:41
  • 1
    @Ovaryraptor Hey, thanks for taking the time to reply. Yes, you are right, I should have provided more detail, so I've gone and updated the post with all the questions you've asked me, and other information which might be useful. Oh, except for the digital map thing, I'll look into that. Thanks again. – Jim Jam May 9 '18 at 18:19
0

Layout is SketchUp's answer to paperspace, where SketchUp itself clearly operates in modelspace, and as such it's not generally a good practice to bring geometric elements from Layout back into SketchUp - it's typically a one-directional-flow from SketchUp to Layout.

This is, however, a guideline, not a hard-and-fast-rule.

If what you're bringing in is relatively simple, you can "go find it" far from the SU origin, and re-zero its location to bring it to the worldspace origin, and use as needed.

Please Note that your warning didn't say it couldn't parse anything, or ignored anything - it successfully imported all your stuff, and then usefully told you it's located a really huge distance (in SketchUp terms) from the world origin.

  • That's the problem, I can't seem to find a way to find what the world origin even is, I presumed that since in Sketchup, am importing it right at the axes, without zooming in or out, that it would be close to the origin. Am confused as to whether it needs to be resized and/or repositioned in layout, or if I need to import it somewhere else in Sketchup, whether I need to change the scale in either program, etc. – Jim Jam May 9 '18 at 18:23
  • You show in your added screencaps that the option is selected for Preserving Drawing's Origin" on export - deselect that. I believe this is you issue. – GerardFalla May 9 '18 at 22:07
  • I tried it, it never worked. Thanks though. – Jim Jam May 10 '18 at 16:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.