0

enter image description here

Writing Arabic in InDesign cs5 has not been a problem ever before, but today it started to annoy me, as I didn't do anything different than I usually do and didn't touch any settings, etc. Kerning is as it was before and has always been on 'zero'.

Even the letters that are joined (blue highlighted) - the attached picture are separating from one another!

I have InDesign CS5 for PC. It is not a Middle Eastern version.

1

This might be a shot in the dark, as I don't have the font you used, but have you checked your composer settings? You should use World-Ready Composer when typesetting in Middle Eastern / Eastern languages, or else the text will just be rendered as individual characters, and not a ligature.

enter image description here

You can access this option by clicking on the fly-out menu of Paragraph panel and selecting one of the two World-Ready options (Single-line or Paragraph).

InDesign Composer options

Oh and, just a friendly advice: don't use pirated webfonts in DTP apps. They can cause more trouble than not.

  • Thanks for your response. I followed your instructions, but sadly I can ONLY see: 'Adobe Paragraph composer' and 'Adobe Single-line composer'. As already mentioned, i didn't have this problem before in all my years working with in InDesign and nor have i fiddled with any settings, and it randomly started playing up.. – Namless Dec 11 '18 at 22:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.