1

Using InDesign CC 2015, I copied a diagram (consisting of some simple vector artwork and text frames, grouped) from one InDesign document into a text frame in another. I used the Transform -> Scale menu item to scale the grouped diagram to 50%. I did this a second time, with another diagram. No problems.

On the third diagram, I got the error message "Unable to set bounding box."

Trying repeatedly, I get the same error.

I tried out of curiosity to scale one of the earlier copied diagrams which had already been successfully scaled down. One of these now gives the same "Unable to set bounding box" error; the other one can scale successfully.

How can I fix this?

  • You do understand that your question does not contain anything for us to debgug? So im afraid any help you may get must be based on a wild guess. Which is not a good way to get answers. But just out of curisoity why didnt you just ink to the origial file? – joojaa May 30 '18 at 10:58
  • @joojaa can’t do that for legal and copyright reasons. But to address the rest of your comment—if Adobe developers were reading this, they could do more than guess wildly. They could examine the source code and find the bug. Or, someone could tell me “this was a known issue fixed in umpty-ump update.” I can dream, anyway. – Wildcard May 30 '18 at 12:08
  • @joojaa tomorrow I will see if I can make a single tiny file with just one corrupt arrow and upload that. Maybe I can send it to Adobe quality control directly; I’d welcome any links in that direction. – Wildcard May 30 '18 at 12:09
  • i dont think so. This error pops up for several different reasons. – joojaa May 30 '18 at 12:38
3

I had this issue too on a diagram in InDesign I was trying to scale down. Turns out the problem was the scaling of the arrows (some kind of InDesign bug?).

I solved this by selecting "none" for the Start and End arrowheads in the stroke panel. Then I scaled down the diagram and applied the arrowheads again where necessary.

0

I was unable to "fix" this per se. The instructions on this page appeared likely to help, but ultimately didn't, at least in my case.

Except for the one suggestion to revert to an earlier version of my file. Fortunately, through sheer dumb luck, I had saved the file immediately before I pasted in the diagrams. I reverted to that.

I also checked the file I was copying the diagrams from, and it appears that I did something to corrupt the diagrams there as well: I was unable to scale the diagrams even in that original file and got the same error.

It's worth noting that the error had infected other parts of the target file: a disrelated text box produced the same error when I attempted to scale it after the corrupt diagram had been copied into the file.

I reverted to an earlier version of the source file as well, checked that I could scale it in the source file, and then copied the verified-not-corrupt diagram to the target file I'm actually working on.


EDIT: Turns out I spoke too soon. I found that one diagram still gave trouble, even in my earlier version of the source file.

By narrowing down the scope of what I selected (after ungrouping the diagram), I found that there was one SINGLE object, a short line with an arrow on it, that produced the error. Any grouping that it was part of would also produce the error.

I believe that the "contagion" observed earlier was actually due to the text box I was trying to resize being an earlier part of the same text flow that (on a separate page) contained the diagram with this one arrow.

I deleted that arrow and redrew it AND THE PROBLEM CONTINUED.

However, I had several other almost identical arrows in the same diagram that didn't produce the problem. I copied one of these, scaled it a little bit to get it pointing the right way (at an angle), and could then scale the whole diagram successfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.