0

I just started using Gimp 2.10, and I love it except for one small thing that is absolutely killing me right now.

When I set the active layer as not visible and then try editing it (I do a lot of pixel art, and I'd take a layer, set it to non visible, and erase a couple pixels so the layer under it would have a few parts that would look like its above the layer that is invisible), but I get a warning at the bottom saying "The active layer is not visible" and it doesn't erase the pixels I'm trying to erase.

I don't want to mess with the layer transparency, or have to make another layer above the other one, so how would I turn off the warning and edit the layer when it isn't set as visible?

  • 1
    GIMP 2.8.x allowed editing pixels on a hidden layer. Perhaps it's a new feature? In any case, you could just unhide the layer, then when you've finished hide it again. – Billy Kerr Jun 2 '18 at 18:20
0

This is a deliberate change from the behavior of 2.8 in GIMP 2.10, and has actually been in the code of the GIMP master branch for quite some time (about 5 years).

The code change was done to implement a feature request: Bug 598523 - Protect hidden layers from editing

You can suggest improvements, for example to make this a configurable option. If you want to do so, then you should file an issue at https://gitlab.gnome.org/GNOME/gimp/issues

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.