0

As shown on image below, drawing in Gimp have big jaws in lines, only when using my graphic tablet, the One by Wacom. Image showing big jaws in lined compared to smooth lines in Paint Tool Sai I'm also sure it is problem of Gimp because when using Paint Tool Sai, lines looks fine. I'm also 100% sure it is problem with graphics tablet because it it does not happening when using mouse. I tried to mess with wacom tablet config and Gimp input setting but i was unable to solve it myself.

Do someone knows how to repair this unpleasant behaviour. By the way. It was fine before, it start to happening several days ago.

  • Sai uses input smoothing, by averaging over several samples of your brush position. this will make the line drawn jitter less. a tiny amount os smoothing is a huge deal, but unnoticable for you. – joojaa Jun 13 '18 at 13:15
1

Here's how to draw nice smooth lines in GIMP. It doesn't matter if you are using a graphics tablet, or a mouse.

In GIMP choose the Brush Tool.

In the Tool Options, choose the following settings - making sure you set the Smooth Stroke options.

enter image description here

Then draw!

enter image description here

GIMP's smoothing works by using a Weight and Quality setting, which causes a slight delay between the cursor and stroke, alowing you to smooth out little jitters caused by using a stylus or a mouse. If you think the effect is too much, you can reduce the quality and weight sliders until you get the optimum behaviour.

Update 1

Even a small amount of smoothing with much lower Weight and Quality settings will make a huge difference, and reduce the delay to virtually nothing. Compare smoothing switched off (on the left), and switched on (on the right).

enter image description here

Update 2

On further investigation of your image file, I can't actually replicate the problem with GIMP and my cheap Wacom Bamboo tablet, even with Smoothing switched off, so I guess something else is wrong. Perhaps the graphics tablet drivers?

This example is with GIMP 2.10.2 - Wacom Bamboo, with Brush Dynamics: Pressure Size turned on, and Smoothing switched off.

enter image description here

  • As i said multiple times before, I know about smooth lines but I cannot use it because it is against my art style. – Jacob Jun 13 '18 at 13:16
  • @Garrom Read the update in my answer. The delay can be reduced to almost nothing. – Billy Kerr Jun 13 '18 at 13:18
  • @Garrom Might be worth noting also that even with Smoothing off, and drawing on your image, I can't replicate the problem. So perhaps something else is up. – Billy Kerr Jun 13 '18 at 13:58
  • @Garrom I've investigated your problem a little further since you provided the actual image file, see the 2nd update in my answer. – Billy Kerr Jun 13 '18 at 15:07
0

Ten to one odds your stroke smoothing (see below) is turned off.

enter image description here

Check both quality and weight settings if indeed smoothing is on - you may have inadvertently altered that setting.

The other major thing to check for is View>Snap to Grid - make sure this is turned OFF for tablet painting.

Wow - just found in fact same advice given previously for similar question:

Gimp - jagged pencil and brush strokes [SOLVED]

  • Hi @GerardFalla . I don't use pressure dynamics or smooth strokes.I don't need pressure dynamics. I can't use smooth strokes because it is against my style (it slows down the cursor). I too found "Gimp - jagged pencil and brush strokes [SOLVED]" but I don't use grid snapping at all, never used .As i said before, it have nothing common with tools because that will affect mouse too and mouse works fine. But anyway, thanks for trying. – Jacob Jun 12 '18 at 17:19
  • @Garrom - the images you post it looks like there's a resolution mismatch - the "jaws" you refer to in the GIMP image look like quantization of what would otherwise be a mostly smooth curve - have you set up (accidentally or intentionally) application-specific profiles in your Wacom preferences? You might try temporarily moving any such profiles to another folder to test, and if it doesn't help (it will force the Wacom driver to write a new blank profile file) you can shift them back in. – GerardFalla Jun 12 '18 at 17:32
  • Hi @GerardFalla .I have two utilities at my disposal. They are "Wacom Preference File Utility" and "Wacom Preferences". No one of them offers application specific profiles.I thought it is something with tablet input setting but after resetting it still happening. It must be something with setting because it did not happening before (but i don't remember changing anything). You are right about resolution. It was two different images put together in Gimp then downscaled to met maximal allowed size of image. – Jacob Jun 13 '18 at 10:02
0

Looks like you are using the Pencil tool and not the Paintbrush. The Pencil is "hard", the Paintbrush is anti-aliased.

  • Nope. Happens with all tools. Must be something with how Gimp process pen data. – Jacob Jun 13 '18 at 9:31
  • Is the image color indexed? And can you post the image as a PNG and not a JPEG? The JPEG compression prevents looking at the real pixels. – xenoid Jun 13 '18 at 12:15
  • You just requested me to upload 17.5 Mb image to stackexchange.com where is 2 Mb limit. I cannot put it here and this 2 Mb limit forced me to use jpg with compression despite I , as pixel artist hate it. I cannot post it here, but I can temporarily store it on my google drive for you. drive.google.com/open?id=1ozsdwRx9QO_QcM0xMOJor1-XxzpKaK_1 – Jacob Jun 13 '18 at 13:22
  • You don't need to export a big image. A 200x200 sample is enough... – xenoid Jun 13 '18 at 14:50
  • When they occur, the straight parts are 11px apart (horizontally and vertically). Anything enabled in View>Snap to {something}? – xenoid Jun 13 '18 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.