0

We are having some weird issue on an AI file. There is some text that has a strong letter spacing, however we checked the settings and it has 0 VA value:

text paragraph

We then tried creating a new text with same settings and another weird thing is happening (no photo for that), when entering space between words the space is being "eaten" by the letter after it. Do we need to start calling father Merrin?

edit: this short video will show the second bug "eating" the space as I type in some text in the box: http://share.creoweb.it/sample.mp4

edit 2: in this test I have set Courier New as font, the problem persist and the new character is eating the previous space: http://share.creoweb.it/sample2.mp4 fun thing, when deleted the space is still there.

word spacing resolved: this link provided how to fix this issue, worked with justification setting, set it to 100% then back to 80% now regardless of it words space correctly now.

letters eating space resolved: the previous link also resolved this issue, the settings were all messed up, restoring correct values allowed me to type the space correctly.

  • And the paragraph alignment of this text is? – Danielillo Jun 22 '18 at 9:22
  • @Danielillo this: share.creoweb.it/para.jpg – S. Redrum Jun 22 '18 at 9:25
  • You can add images at the question when editing. Go to Menu Type > Show Hidden Characters and add the text capture. Is the text copy/paste from another text program? – Danielillo Jun 22 '18 at 9:30
  • @Danielillo I can't find the Meny Type in AI. The text should be typed in, what also I don't understand is why making a new text will add no spaces, what should I check? – S. Redrum Jun 22 '18 at 10:14
  • 1
    That pink background in the video says "Hey, you have selected a font that is not available on your system!". That could be a problem. Try with a font that you actually have. – usr2564301 Jun 22 '18 at 10:27
3

The font you are typing is not Roboto Condensed Regular - some font subsitution has taken place. Looks like the font is not installed on your system.

enter image description here

  • But I'm assuming it's only part of the problem (or possibly hiding the underlying cause) because even with substitute fonts, Illustrator should not be eating those spaces. (I would test that, but how do you forcibly use a not-available font in Illustrator?) – usr2564301 Jun 22 '18 at 11:49
  • 1
    @usr2564301 perhaps, but the issue might be what particular font it has been substituted with. Some people have all sorts of corrupted/defective fonts installed on their computers from sites offering "free" fonts. To be honest it doesn't take much to confuse poor old Illustrator. The OP should at least install the right font to see if it rectifies the problem. If not, then the problem would lie elsewhere. – Billy Kerr Jun 22 '18 at 12:00
  • @BillyKerr I used a fond (new edit) but the problem persist. I'm thinking of some document wide setting, like if who did it is from a different country and using some weirdly different settings. – S. Redrum Jun 22 '18 at 12:39
  • What do you mean by "new edit"? Have you installed Roboto Condensed Regular or not? You can download the proper font from google fonts. After installing the correct font, close the document, do not save it. Now open the original document that was sent to you. Stop messing around with other fonts. – Billy Kerr Jun 22 '18 at 12:49
  • @BillyKerr all good, see my latest edit, problem was with justification settings all messed up. – S. Redrum Jun 22 '18 at 13:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.