2

I can't find the option to turn off the pixel grid in Illustrator CC 2018.

I unchecked the "Snap to Pixel" by clicking on the top right list icon, but I don't see the little magnet icon seen in Illustrator CC 2017.

I don't either see the option to turn it off on the new document settings, even in the advanced and more settings options.

Some screenshots here :

General view General view

Transform box options Transform box options

New document pop-up New document pop-up

New document pop-up "More Settings" option New document pop-up "More Settings" option

  • Possible duplicate of Illustrator CC: Turn off align objects to pixel grid – Danielillo Jun 29 '18 at 10:31
  • 1
    In fact I was reading this post before asking my question because I can't see that little magnet icon in CC 2018. I just added some screenshots. – Bolos Jun 29 '18 at 10:43
  • Maybe this link can help reddit.com/r/AdobeIllustrator/comments/5bt4mn/… – Danielillo Jun 29 '18 at 10:50
  • Found a solution! The magnet icon isn't visible in the "Essentials" view. When I switched "Essentials classic" it appeared, I disabled it and now I can align my vertices to the grid. – Bolos Jun 29 '18 at 11:13
  • Great. Put this comment as an answer to help other users in future questions. – Danielillo Jun 29 '18 at 11:21
1

The magnet icon isn't visible in the "Essentials" view. Switch to "Essentials classic" to make it visible again, disable it and now vertices can be aligned to the grid.

1

After some digging around I found out the root cause. Snap to Pixel is on or off by default depending what Profile is selected when making a new document.

With the "More Settings" view, right under "Name" is "Profile." Chances are it says [custom] now, this happens if you change any of the default parameters, but in all other respects it keeps making new documents according to what the last option defaults.

Snap to Pixel is on by default with "Web" or "Mobile" profiles. Select anything else and it should be off.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.