0

I have expanded my text and trying to add a gradient mesh I created on top of the text to the text beneath but every time this dialog box appears:

Can't make clipping mask

This is what my layer panel looks like:

enter image description here

This is what the clipping mask looks like: clipping mask

This is what the expanded text beneath looks like: enter image description here

  • 2
    Top object clips bottom object, are you sure you dont want to put the mesh behind. – joojaa Jul 17 '18 at 7:29
  • @joojaa I was confused because I have earlier worked in Photoshop and there things were different. – Manas Singh Jul 17 '18 at 9:55
3

The error dialog box tells you what you must do. You can only use a single (compound path) as a clipping mask. Also your layers are the wrong way round.

After you Expand the text to outlines, use Object > Compound Path > Make.

Now you can use the letters as a clipping mask on the gradient mesh. In Illustrator the letters need to be above the gradient mesh, not below! (the exact opposite of Photoshop)

enter image description here

You can also use an editable text object as a clipping mask directly, without expanding the text to outlines or making a compound path.

enter image description here

The beauty of doing it this way is that the text is still editable.

enter image description here

  • Yes I arranged the layers the wrong way. Thanks for pointing that and for the compound path thing too. – Manas Singh Jul 17 '18 at 9:57
  • @ManasSingh - yes, Photoshop is quite different from Illustrator. Best to forget Photoshop completely when working with vectors in Illustrator. The user interface may look superficially similar, but that's where the similarities really end. – Billy Kerr Jul 17 '18 at 13:22
1

You can't create a Clipping Mask with an object different than a regular path.

Instead of using a Clipping Mask, create a Transparency Mask

  • Create a 100% black Compound Shape over the Gradient Mesh leaving free the visible area, the text

Compound Shape

  • Select the Gradient Mesh and the Compound Shape
  • From the Transparency Panel > Make Mask
  • Uncheck Clip
  • Click the left square from the Transparency Panel to go back to the editing area

enter image description here

  • Maybe op wants the text to clip the gradient mask – joojaa Jul 17 '18 at 7:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.