0

My client sent me an .ai file with vector elements in it and a PNG embedded. When I zoom into the .png element, it looks like it was created with anti-aliased turned off. But when I open the file in Photoshop, I import the .pdf with anti-aliased checked off (for the vector elements to come in aliased) and the .png element now has anti-aliasing! (Feathered edges!)

I cannot for the life of me figure out why this is happening.

Original Illustrator file

Zoom 1

Zoom 2

Zoom 3

Photoshop Import

Zoom 4

Zoom 5

Zoom 6

  • yeah AI does nearest neighborhood sampling. – joojaa Jul 28 '18 at 11:05
1

I think your issue is the following (I would have to have access to the original file to be 100% sure):

The original PDF contains both vector graphics and an embedded image with sharp edges (no anti-aliasing).

When you rasterize it in Photoshop you force it to be 15x15 inches at 300 PPI. This seems to be a lower resolution than the original embedded image so Photoshop introduces feathered edges when downsampling. Unchecking the "Anti-aliased" checkbox only affects vector graphics.

If you are worried about print quality, you should check the resolution of the placed image in Illustrator. Select the image and you can see the effective ppi in the "Control" panel:

You probably want the image to be +300 PPI, but be aware that this limit only applies to anti-aliased images. If the image is +1200 PPI you don't need anti-aliasing and the image will probably print nice and sharp (like vector graphics). If the resolution of an aliased image is below 1200 PPI, you might get a problem with visible chunky pixels.

If you, for some reason, want to create a rasterized version in Photoshop with no anti-aliasing, you need to setup the "Import PDF" to the same size as the original PDF at the same resolution as the embedded image.

I hope this answers your question.

0

Not sure what you have there, but most likely the PNG included in the AI is either missing (if linked) or simply a pixelated, low resolution PNG (if embedded).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.