I have duplicated an object. In the attached screenshot, this object is outlined with a dashed white line.

I would now like to use the Eraser to delete a part of that object. However, GIMP doesn't allow this. When I hover over the selected object, the cursor turns into a stop sign.

How could I delete a part of the object?

Thank you!

enter image description here

  • Any chance you don't have the correct layer selected? – Joonas Aug 6 '18 at 11:37
  • I can't replicate this problem. Do you perhaps have "lock alpha channel" engaged on the layer? Can you show us your layers? Please edit your question and add more information, otherwise trying to find out what the problem is can only be guesswork. – Billy Kerr Aug 6 '18 at 12:00
  • @Joonas Thank you, but I think I have the correct layer selected. I have added a new screenshot to show the layers as well. BillyKerr Thanks to you, too. I don't think so. Can you see that from my new screenshot? – tmighty Aug 6 '18 at 17:19
  • I'm going to add an answer now. – Billy Kerr Aug 6 '18 at 19:30

I can see the image you have selected is on a floating selection. That's probably the problem. Also by default, the Lock Alpha option is engaged on floating selections. You could deselect it, and that would allow you to use the eraser.

This shows the floating selection:

enter image description here

This shows the Lock Alpha Channel icon

enter image description here

When you paste something in GIMP, you then need to choose what to do with the floating selection. If you want to promote it to a layer of its own, right click the floating selection layer in the layers panel and choose "To new layer". If you want to merge it to the existing layer, hit the Anchor icon in the layers panel (or press CTRL+H). These actions will also release the Lock Alpha button.

You can avoid these extra steps when pasting if you click Paste As > New Layer instead. That will paste the image on a layer of its own, and the Lock Alpha option will not be engaged either.

| improve this answer | |
  • Paste as new layer loses the position of the pasted bit... It is usually better to use Layer>To new layer or better, its shortcut (Ctrl-Shift-N). – xenoid Aug 6 '18 at 20:53
  • Above, you don't say how to deselect the locked alpha channel. I can't find where this control is. – user133732 Feb 22 '19 at 22:31
  • Checkerboard icon above the layer thumbnails in the Layers list. – xenoid Feb 22 '19 at 23:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.