0

When I edit the guide dimensions it keeps reverting to mm measurement. I just want inches and the document is in inches. How do I stop Inkscape from using the metric system by default?

enter image description here

1

Change both of the settings circled in red to "in".

enter image description here

When you do that, all measurements will be in inches.

enter image description here

If you want to make inches your default units, make a new blank document, set the document properties settings to inches as shown above, and overwrite the default SVG file in your inkscape templates folder. I don't know where that is located on a Mac, but in Windows it's located in the program files/inkscape/share/templates folder.

By the way, the metric system is not a just European thing. The whole world is metric, except the US, Liberia, and Burma. And here in the UK although metric is the official system, we also still use the Imperial system.

  • Additional info: there exists an inches template already, which you can use by going to File > New from template > default inch. The 'display unit' setting is the only one that is relevant in this case, the other unit (for the document size) could stay as it is. To truly make the document use inches internally (for use with outside programs that are not respecting the complete SVG standard), you would then also need to change the 'Scale' value to 1 - but this will make the current content of the file change size, so you'd need to resize that. – Moini Aug 14 '18 at 23:23
  • 1
    @Moini but if you want to create a custom size document in inches though, better to also change the units in the custom size section to inches so the size can be input in inches. Also in my new from template list in Inkscape 0.92.3 there is no default inch template available – Billy Kerr Aug 14 '18 at 23:43
  • True... I'll edit my comment. Thought that would exist, together with the px and pt ones... :-/ Sorry! – Moini Aug 15 '18 at 1:38
  • Editing doesn't work for me... lol. So it's gonna stay there now. – Moini Aug 15 '18 at 1:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.