0

My clipped path is just an uneditable symbol, unless I paste it into a new document. I know it's still a path, but I can't edit it with the node selector.

What is the reason for this error?

The file (579kb) is an SVG generated by Maperative, an application for drawing maps based on OpenStreetMap and GPS data.

Here's a screenshot of the layers. Note that I have tried to convert them to object, to no avail.

3
  • It is difficult to give an answer with so little information. Can you update your question including the SVG file? Aug 16, 2018 at 14:10
  • Can we see a screenshot of your layers panel? The question should be answerable without having to interact with your files / computer
    – Luciano
    Aug 16, 2018 at 16:04
  • It looks like there are several clones contained in the document. It would seem this was not originally created in Inkscape but something called "Maperative". Not entirely sure how you could unpick this for editing, but repeated Edit > Clone > Unlink Clone commands would probably do it, although when I tried it just messes everything up even more.
    – Billy Kerr
    Aug 16, 2018 at 18:35

1 Answer 1

1

Quite a mess, I say. It is generated by software and not organized for manual edits in Inkscape, but for keeping all under control in the generating software.

All parts of type use1234 in objects list are clones of something which is hidden. Inkscape do not edit them until you break the linking. That happens when you copy some useXXXX to another document. In addition there are clipping masks and groupings.

Edit > Select all in all layers and pasting to another document brings everything to editable form. Objects useXXXX are now groups and clipping masks seem to be vanished. There obviously were a document wide mask or layer wide masks. Unfortunately the grid also vanished.

NOTE: You can select an item in a group via the objects panel for edits.

Selecting all in all layers and applying Edit > Clone > Unlink also released the objects to groups, but biggest clipping masks still stayed. The grid survived.

Many open curves got a fill when they were copied and pasted or unlinked. Fortunately selecting all in all layers again all allowed removing fills and there were no intentionally colored closed areas.

enter image description here

I think this is only a partial solution. There were plenty of symbols in the symbol list with no visible usage. What they are becomes visible, if you drag them to the artboard.

Where are the texts and all those symbols is still not solved. I believe it's not a right assumption they are left intentionally out of the map.

2
  • Thanks. I'll try to figure out if I can edit the source code, to change these symbols to layers. Any clue how to go about that?
    – uhl
    Aug 17, 2018 at 14:10
  • @uhl Sorry, I'm weak in programming. Hopefully some other give a better answer. Insert the new problem to some programming site or at least to your question. BTW. the symbols can be dragged to a layer from the symbol list, but there's no idea where they should already be placed
    – user82991
    Aug 17, 2018 at 14:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.