In Gimp, I have one large selection that resulted from attaching multiple smaller selections to each other. Unfortunately, some of these selections were mistakenly created with feathering applied, causing slivers of partially selected areas that I want to get rid of now.

I confirmed this by opening the Selection Editor, which shows fully selected areas in white, unselected areas in black, and partially selected areas in a shade of grey. Is there any way I can apply a threshold function of sorts to turn all these greys into white?

2 Answers 2


Blunt way:

Select>Sharpen (which thresholds at 128)

More accurate way:

  • Enter "Quick mask" mode
  • Use the Threshold tool (or any paint/color tool, for that matter) to fix the selection.
  • Exit quickmask mode

enter image description here


One method is to use a layer mask to temporarily store your selection, so that you can edit it as you would any other image, much like the image you can see in the Selection Editor panel.

  • Add a layer mask to a new blank layer. Choose the option "from seletion" when applying the mask. This will store your current selection as an image much like the one you can see in the selection editor panel. At this point you can release your selection, since it's safely stored in the layer mask.
  • Right click the layer mask thumbnail, and choose Show Layer Mask, and make sure you click the layer mask thumbnail to select it.
  • Now you can apply the threshold filter, or edit the mask by painting on it etc.
  • After you have edited it, turn it back into a selection by right clicking the layer mask thumbnail and choosing Mask to Selection.
  • You can hide the layer mask by right clicking and uncheck the Show Layer Mask option. And obviously you can delete the layer with the mask if you have no need for it.
  • Less artificially, you can save the selection to a channel, edit the channel, and set the selection from the result. But this is still way too complicated compared to using the quickmask...
    – xenoid
    Commented Aug 19, 2018 at 13:39
  • @xenoid - yes, I forgot about the Quickmask.
    – Billy Kerr
    Commented Aug 19, 2018 at 14:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.